Project

General

Profile

Bug #25515

Subscription detail page is empty

Added by Dirk Götz over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

I found the subscription detail page empty while debugging a problem with subscriptions (running Katello 3.8.0). On my personal demo system which was still 3.6 it worked, but running all the updates from 3.7 over 3.8 to 3.9 I found the page always empty. The browser console or the logs do not show an error.

To reproduce go to Content > Subscriptions and click on the name of the subscription. (https://KATELLOHOST/subscriptions/1/)

I also tried an API call which gives me the subscription details (https://KATELLOHOST/katello/api/organizations/1/subscriptions/1).

Associated revisions

Revision 1ecd066b (diff)
Added by Ewoud Kohl van Wijngaarden about 2 years ago

Fixes #25515 - Fix React router paths (#7994)

  • Refs #25515 - Mount React components in the body

Otherwise the result is:

</html>
<script defer="defer">
//<![CDATA[
$(tfm.reactMounter.mount('katello', '#reactRoot', [], false));
//]]>
</script>

Script tags are not supposed to show up outside of HTML.

  • Fixes #25515 - Fix react router paths

The Route paths are already using exact. Otherwise (at least in nightly)
you need to use /subscriptions/1$/ as a path. The regex is also changed
to require at least one number.

History

#1 Updated by John Mitsch over 2 years ago

  • Status changed from New to Need more information

We can double check if these pages work in the releases you mention, but can you try a few things first?

- Try a hard refresh of the browser page
- Try a different browser i.e. chrome instead of firefox
- Try an 'incognito' window or its equivalent

Let us know if any of these resolve the issue. If not, some information on your browser and version would be helpful. Also, please double check for browser console errors during the refresh.

#2 Updated by Dirk Götz over 2 years ago

I tried it again with all my browsers on Fedora 28:
- Basilisk 2018.11.07
- Firefox 63.0.1
- Chrome 70.0.3538.110

Colleagues also use a different mixture of Safari, Firefox and Chrome on MacOS and it does not work for them, too.

#3 Updated by Christine Fouant over 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello Backlog
  • Status changed from Need more information to New

#4 Updated by Tony Coffman over 2 years ago

Found the same thing in 1.20.1/Katello 3.10

Looking at /subscriptions/<subscription number> results in a blank page. I was able to use /legacy_subscriptions as a workaround.

In 3.10, the /subscriptions page shows a data grid but the boxes are empty which sounds like it might be a different (new) bug?

#5 Updated by Jonathon Turel about 2 years ago

  • Triaged changed from Yes to No
  • Target version changed from Katello Backlog to Katello 3.11.0

Marking this for triage into an upcoming release. It still does not work in nightly builds but doesn't seem easily reproducible in development environments even when running in production mode with precompiled assets.

#6 Updated by Chris Roberts about 2 years ago

  • Triaged changed from No to Yes
  • Assignee set to Walden Raines
  • Status changed from New to Assigned

#7 Updated by Walden Raines about 2 years ago

Just a quick update with my findings so far.

I can reproduce this in katello 3.11 production and in nightly production. I can not reproduce this in master or when checking out katello 3.11 directly. I also cannot reproduce this in the relevant downstream releases.

There are no javascript errors and no errors in the production log.

The above leads me to believe that this is a packaging issue (perhaps a missing package or an outdated one). Will continue to investigate further.

#8 Updated by Jonathon Turel about 2 years ago

  • Target version changed from Katello 3.11.0 to Katello 3.9.2

#9 Updated by The Foreman Bot about 2 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7994 added

#10 Updated by Ewoud Kohl van Wijngaarden about 2 years ago

  • Status changed from Ready For Testing to Closed

#11 Updated by Ewoud Kohl van Wijngaarden about 2 years ago

  • Triaged changed from Yes to No
  • Fixed in Releases Katello 3.12.0 added

This will need cherry picks. Removing triaged so the triage team can properly look at this.

#12 Updated by John Mitsch about 2 years ago

  • Triaged changed from No to Yes

#13 Updated by Jonathon Turel about 2 years ago

  • Target version changed from Katello 3.9.2 to Katello 3.10.1

Also available in: Atom PDF