Project

General

Profile

Bug #25529

Module file in Red Hat 7 repositories causes metadata error

Added by Dirk Götz over 3 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I have no idea why but we found a modules.yaml.gz in "Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server" repository causing problems on the clients with not matching checksums. I could reproduce this with my personal demo system with Katello 3.9.0 by simply adding and syncing the repository. Problem is not fixed by "Republish Repository Metadata" action.

My directory listing looks like:

    256ee8de899e601eef6b5676c0af15705d02b035-filelists.xml.gz
    42b9a64734e0366bfb45e20eccfccf42920fe2d8-updateinfo.xml.gz
    56598dca26b1c4f05475e5ae52bba07c18077611-comps.xml
    6c2c5f8e280f123ee2a47c83b53cc57e605868a0-other.xml.gz
    824ffe238f202a0612ecbb2b0c0459dc289a7ef47adb1f26406453d41f476449-modules.yaml.gz
    effe8437a8a71e15cb72e29af7ad3bb7625fdeb0-primary.xml.gz
    productid
    repomd.xml

The repomd.xml looks (prettified) like:

<repomd>
  <revision>1542811545</revision>
  <data type="filelists">
    <location href="repodata/256ee8de899e601eef6b5676c0af15705d02b035-filelists.xml.gz"/>
    <timestamp>1542811798</timestamp>
    <size>31765558</size>
    <checksum type="sha1">256ee8de899e601eef6b5676c0af15705d02b035</checksum>
    <open-size>438921952</open-size>
    <open-checksum type="sha1">e991eeabdd7ea852ca1422801fe3014abb15cd8d</open-checksum>
  </data>
  <data type="other">
    <location href="repodata/6c2c5f8e280f123ee2a47c83b53cc57e605868a0-other.xml.gz"/>
    <timestamp>1542811802</timestamp>
    <size>17970955</size>
    <checksum type="sha1">6c2c5f8e280f123ee2a47c83b53cc57e605868a0</checksum>
    <open-size>67172179</open-size>
    <open-checksum type="sha1">3710cc7bd6efd3fd8ddce382f57919f44c60b2f3</open-checksum>
  </data>
  <data type="primary">
    <location href="repodata/effe8437a8a71e15cb72e29af7ad3bb7625fdeb0-primary.xml.gz"/>
    <timestamp>1542811802</timestamp>
    <size>34006158</size>
    <checksum type="sha1">effe8437a8a71e15cb72e29af7ad3bb7625fdeb0</checksum>
    <open-size>243554689</open-size>
    <open-checksum type="sha1">06a1f19106599a8d22e3b2faabd38b48ecff9c37</open-checksum>
  </data>
  <data type="updateinfo">
    <location href="repodata/42b9a64734e0366bfb45e20eccfccf42920fe2d8-updateinfo.xml.gz"/>
    <timestamp>1542811864</timestamp>
    <size>3229948</size>
    <checksum type="sha1">42b9a64734e0366bfb45e20eccfccf42920fe2d8</checksum>
    <open-size>16822069</open-size>
    <open-checksum type="sha1">63fb0c4ac911e7a3d00ffb389aeb274872ea5aad</open-checksum>
  </data>
  <data type="modules">
    <location href="repodata/824ffe238f202a0612ecbb2b0c0459dc289a7ef47adb1f26406453d41f476449-modules.yaml.gz"/>
    <timestamp>1542811864</timestamp>
    <size>33</size>
    <checksum type="sha1">824ffe238f202a0612ecbb2b0c0459dc289a7ef47adb1f26406453d41f476449</checksum>
    <open-size>0</open-size>
    <open-checksum type="sha1">da39a3ee5e6b4b0d3255bfef95601890afd80709</open-checksum>
  </data>
  <data type="group">
    <location href="repodata/56598dca26b1c4f05475e5ae52bba07c18077611-comps.xml"/>
    <timestamp>1542811865</timestamp>
    <size>791487</size>
    <checksum type="sha1">56598dca26b1c4f05475e5ae52bba07c18077611</checksum>
  </data>
  <data type="productid">
    <location href="repodata/productid"/>
    <timestamp>1542804044</timestamp>
    <size>2159</size>
    <checksum type="sha1">715fccfd9458f968d747f743979d7e79a0fb2177</checksum>
  </data>
</repomd>

So it looks like it uses sha1 by default but has only a sha256 checksum for modules.yaml.gz.

$ sha1sum 824ffe238f202a0612ecbb2b0c0459dc289a7ef47adb1f26406453d41f476449-modules.yaml.gz 
4eece298b20d31d4aeb1ec96fcf072c7ad42f137  824ffe238f202a0612ecbb2b0c0459dc289a7ef47adb1f26406453d41f476449-modules.yaml.gz
$ sha256sum 824ffe238f202a0612ecbb2b0c0459dc289a7ef47adb1f26406453d41f476449-modules.yaml.gz 
824ffe238f202a0612ecbb2b0c0459dc289a7ef47adb1f26406453d41f476449  824ffe238f202a0612ecbb2b0c0459dc289a7ef47adb1f26406453d41f476449-modules.yaml.gz

History

#1 Updated by John Mitsch over 3 years ago

  • Target version set to Katello 3.9.1

#2 Updated by John Mitsch over 3 years ago

  • Triaged changed from No to Yes

#3 Updated by Justin Sherrill over 3 years ago

  • Status changed from New to Rejected

The following pulp issues were opened as a result of this report:

https://pulp.plan.io/issues/4253
https://pulp.plan.io/issues/4252

We will have to wait for these fixes to be released in order for the issue to be resolved. Nothing katello can do here, so closing.

#4 Updated by Zach Huntington-Meath over 3 years ago

  • Target version changed from Katello 3.9.1 to Katello 3.9.2

#5 Updated by Zach Huntington-Meath about 3 years ago

  • Target version changed from Katello 3.9.2 to Katello Recycle Bin

Also available in: Atom PDF