Project

General

Profile

Bug #25561

Upgrade from 6.4.0 to 6.4.1 failed at Upgrade Step: remove_legacy_mongo

Added by Chris Roberts over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
trivial
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from BZ:

Description of problem:

z-stream upgrade i.e. 6.4.0 to 6.4.1 upgrade failed at

<trimmed>
Upgrade Step: migrate_foreman...
/usr/share/foreman/lib/foreman.rb:8: warning: already initialized constant Foreman::UUID_REGEXP
/usr/share/foreman/lib/foreman.rb:8: warning: previous definition of UUID_REGEXP was here
/usr/share/foreman/lib/core_extensions.rb:182: warning: already initialized constant ActiveSupport::MessageEncryptor::DEFAULT_CIPHER
/opt/theforeman/tfm-ror51/root/usr/share/gems/gems/activesupport-5.1.6/lib/active_support/message_encryptor.rb:22: warning: previous definition of DEFAULT_CIPHER was here
API controllers newer than Apipie cache! Run apipie:cache rake task to regenerate cache.
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/content_facet_host_extensions.rb:7: warning: already initialized constant Katello::Concerns::ContentFacetHostExtensions::ERRATA_STATUS_MAP
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/content_facet_host_extensions.rb:7: warning: previous definition of ERRATA_STATUS_MAP was here
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/content_facet_host_extensions.rb:14: warning: already initialized constant Katello::Concerns::ContentFacetHostExtensions::TRACE_STATUS_MAP
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/content_facet_host_extensions.rb:14: warning: previous definition of TRACE_STATUS_MAP was here
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/subscription_facet_host_extensions.rb:13: warning: already initialized constant Katello::Concerns::SubscriptionFacetHostExtensions::SUBSCRIPTION_STATUS_MAP
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/subscription_facet_host_extensions.rb:13: warning: previous definition of SUBSCRIPTION_STATUS_MAP was here
foreman-rake db:migrate finished successfully!
Upgrade Step: remove_legacy_mongo...
Upgrade step remove_legacy_mongo failed. Check logs for more information.

Version-Release number of selected component (if applicable):

Upgrade from 6.4.0 to 6.4.1

How reproducible: always

Steps to Reproduce:
1. foreman-maintain upgrade run --target-version 6.4.z -y

Actual results:
Upgrade failed at Upgrade Step: remove_legacy_mongo

Expected results: Successful upgrade.

History

#1 Updated by Chris Roberts over 3 years ago

  • Status changed from New to Closed

#2 Updated by Chris Roberts over 3 years ago

  • Found in Releases Katello Recycle Bin added

#3 Updated by Chris Roberts over 3 years ago

  • Fixed in Releases Katello Recycle Bin added

#4 Updated by Christine Fouant over 3 years ago

  • Triaged changed from No to Yes

#5 Updated by Zach Huntington-Meath over 3 years ago

  • Target version changed from Katello 3.9.1 to Katello Recycle Bin

Also available in: Atom PDF