Project

General

Profile

Bug #25604

[6.4]After unregistering hypervisor, unable to view subscriptions on activation key via Satellite WebUI

Added by Samir Jha almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Activation Key
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1648121

Initial setup is an activation key with one or more derived entitlements attached.

[root@iridium ~]# hammer activation-key subscriptions --id 4 --organization-id 1
---|----------------------------------------------------------------------------------|----------|----------|---------------------|---------------------|----------|----------|--------
ID | NAME | ATTACHED | QUANTITY | START DATE | END DATE | SUPPORT | CONTRACT | ACCOUNT
---|----------------------------------------------------------------------------------|----------|----------|---------------------|---------------------|----------|----------|--------
9 | Red Hat Enterprise Linux for Virtual Datacenters with Smart Management, Standard | | | 2017/02/07 05:00:00 | 2021/12/31 23:59:59 | Standard | 11288968 | 540155
8 | Red Hat Enterprise Linux for Virtual Datacenters with Smart Management, Standard | | | 2017/02/07 05:00:00 | 2021/12/31 23:59:59 | Standard | 11288968 | 540155
---|----------------------------------------------------------------------------------|----------|----------|---------------------|---------------------|----------|----------|--------
[root@iridium ~]#

One the Satellite WebUI, when viewing 'list/remove subscriptions' for the activation key, this appears as in screenshot1.png.

Then the issue is reproduced by unregistering one hypervisor associated with one of the derived entitlements on the key. At this point, when viewing 'list/remove subscriptions' on the WebUI, this appears in the broken state as in screenshot2.png.

However using Hammer, I am still able to view the one remaining subscription on the key:

[root@iridium ~]# hammer activation-key subscriptions --id 4 --organization-id 1
---|----------------------------------------------------------------------------------|----------|----------|---------------------|---------------------|----------|----------|--------
ID | NAME | ATTACHED | QUANTITY | START DATE | END DATE | SUPPORT | CONTRACT | ACCOUNT
---|----------------------------------------------------------------------------------|----------|----------|---------------------|---------------------|----------|----------|--------
8 | Red Hat Enterprise Linux for Virtual Datacenters with Smart Management, Standard | | | 2017/02/07 05:00:00 | 2021/12/31 23:59:59 | Standard | 11288968 | 540155
---|----------------------------------------------------------------------------------|----------|----------|---------------------|---------------------|----------|----------|--------
[root@iridium ~]#

When I re-register the hypervisor by re-running virt-who, then attach the physical VDC subscription to the hypervisor again, then attach the derived VDC subscription to the activation key, suddenly all subscriptions are showing again on the activation key under 'list/remove subscriptions'.

I have verified this behavior on 6.3.1 and 6.4. It appears to be reproducible 100% of the time.

Associated revisions

Revision 8e2ebe8d (diff)
Added by Samir Jha almost 2 years ago

Fixes #25604 - Pools not deleted in katello

History

#1 Updated by The Foreman Bot almost 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7870 added

#2 Updated by Andrew Kofink almost 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.10.0

#3 Updated by Anonymous almost 2 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF