Project

General

Profile

Bug #25733

Media provider unique ID does not work for Debian-based distros

Added by Lukas Zapletal about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Unattended installations
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

Debian installation media have no variables in it (e.g. http://archive.ubuntu.com/ubuntu) so the unique id is calculated the same for all operating systems and does not actually work. We need to generate it from pxedir, e.g. http://sg.archive.ubuntu.com/dists/main/installer-x86_64/current/images/netboot/ubuntu-installer/x86_64.


Related issues

Related to Foreman - Bug #26154: NoMethodError: undefined method `pxedir' for #<Windows:0x0000000007298338>Closed
Related to Foreman - Bug #28965: Regression: Since #19389 boot image of debian is not updated and installation is brokenClosed

Associated revisions

Revision 4808ee94 (diff)
Added by Lukas Zapletal about 1 year ago

Fixes #25733 - PXE uid generated from pxedir

Revision a3df1ae0 (diff)
Added by Tomer Brisker about 1 year ago

Refs #25733 - Fix medium_provider test for ubuntu

Debain-based distros now require relname property, os fixtures were
updated with them while the test wasn't because the PR wasn't rebased
prior to merging.

History

#1 Updated by The Foreman Bot about 1 year ago

  • Assignee set to Lukas Zapletal
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6352 added

#2 Updated by Tomer Brisker about 1 year ago

  • Fixed in Releases 1.20.2, 1.21.0 added

#3 Updated by Lukas Zapletal about 1 year ago

  • Status changed from Ready For Testing to Closed

#4 Updated by The Foreman Bot about 1 year ago

  • Pull request https://github.com/theforeman/foreman/pull/6416 added

#5 Updated by Tomer Brisker 12 months ago

  • Related to Bug #26154: NoMethodError: undefined method `pxedir' for #<Windows:0x0000000007298338> added

#6 Updated by Tomer Brisker 14 days ago

  • Has duplicate Bug #28965: Regression: Since #19389 boot image of debian is not updated and installation is broken added

#7 Updated by Tomer Brisker 14 days ago

  • Has duplicate deleted (Bug #28965: Regression: Since #19389 boot image of debian is not updated and installation is broken)

#8 Updated by Tomer Brisker 14 days ago

  • Related to Bug #28965: Regression: Since #19389 boot image of debian is not updated and installation is broken added

Also available in: Atom PDF