Project

General

Profile

Bug #25750

Recommended Repositories lists tools for outdated Satellite version

Added by Evgeni Golov 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1661422

Description of problem:
On Satellite 6.4, the RH repositories page (/redhat_repositories) lists 6.3 Tools and Capsule as "recommended" repositories, instead of their 6.4 counterparts.

Version-Release number of selected component (if applicable):
satellite-6.4.0-15.el7sat.noarch
tfm-rubygem-katello-3.7.0.41-1.el7sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. go to https://satellite/redhat_repositories
2. toggle "Recommended Repositories" to ON

Actual results:
Red Hat Satellite Capsule 6.3 (for RHEL 7 Server) (RPMs)
Red Hat Satellite Capsule 6.4 (for RHEL 7 Server) (RPMs)
Red Hat Satellite Tools 6.3 (for RHEL 6 Server) (RPMs)
Red Hat Satellite Tools 6.3 (for RHEL 7 Server) (RPMs)

Expected results:
Red Hat Satellite Capsule 6.4 (for RHEL 7 Server) (RPMs)
Red Hat Satellite Tools 6.4 (for RHEL 6 Server) (RPMs)
Red Hat Satellite Tools 6.4 (for RHEL 7 Server) (RPMs)

Additional info:
See screenshot

Associated revisions

Revision a293cac8 (diff)
Added by Evgeni Golov 6 months ago

Fixes #25750 - update recommended satellite versions

this also slightly re-structures the data into three lists, grouped by
topic

History

#1 Updated by The Foreman Bot 6 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7904 added

#2 Updated by Evgeni Golov 6 months ago

  • Assignee set to Evgeni Golov
  • Subject changed from Recommended Repositories lists tools for outdated Satellite version to Recommended Repositories lists tools for outdated Satellite version

#3 Updated by Evgeni Golov 6 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Justin Sherrill 6 months ago

  • Target version set to Katello 3.11.0

#5 Updated by Justin Sherrill 6 months ago

  • Triaged changed from No to Yes

Also available in: Atom PDF