Project

General

Profile

Bug #25751

Product sync: wrong link to task

Added by Samir Jha 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1648903

Description of problem:
When syncing product content from a Products page, a notification appears saying the sync has started and containing a verbatim HTML of the link to task.

Version-Release number of selected component (if applicable):
Reproduced with 6.5

How reproducible:
Deterministic

Steps to Reproduce:
1. Have some product (happens both to custom products and to RH repos)
2. In the WebUI: Content -> Products -> <select the product> -> Select Action -> Sync Selected

Actual results:
A green notification appears saying: "Product sync has been initiated in the background. Click <a href=foreman_tasks/tasks/...>here</a> to monitor the progress."

Expected results:
The link tag should be interpreted as a link, not shown verbatim.

Additional info:
No traceback

Associated revisions

Revision 02d8b97a (diff)
Added by Samir Jha 5 months ago

Fixes #25751 - Task link on product sync

History

#1 Updated by The Foreman Bot 6 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7905 added

#2 Updated by Justin Sherrill 5 months ago

  • Target version set to Katello 3.11.0
  • Category changed from ElasticSearch to Repositories

#3 Updated by Justin Sherrill 5 months ago

  • Triaged changed from No to Yes

#4 Updated by Anonymous 5 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF