Project

General

Profile

Bug #25830

syncing a content view puppet environment to a smart proxy fails a refresh step

Added by Justin Sherrill 8 months ago. Updated 6 months ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Likely caused by 80889fdbd393d8c072c7b1ca8fe39a8260c866d7

Error:

NoMethodError

undefined method `backend_service' for nil:NilClass

---
- "/home/vagrant/git/katello/app/lib/actions/pulp/repository/refresh.rb:17:in `run'" 
- "/home/vagrant/.rvm/gems/ruby-2.5.1/gems/dynflow-1.2.0/lib/dynflow/action.rb:539:in
  `block (3 levels) in execute_run'" 
- "/home/vagrant/.rvm/gems/ruby-2.5.1/gems/dynflow-1.2.0/lib/dynflow/middleware/stack.rb:26:in
  `pass'" 
- "/home/vagrant/.rvm/gems/ruby-2.5.1/gems/dynflow-1.2.0/lib/dynflow/middleware.rb:18:in
  `pass'" 
- "/home/vagrant/.rvm/gems/ruby-2.5.1/gems/dynflow-1.2.0/lib/dynflow/middleware.rb:31:in
  `run'" 
- "/home/vagrant/.rvm/gems/ruby-2.5.1/gems/dynflow-1.2.0/lib/dynflow/middleware/stack.rb:22:in
  `call'" 
- "/home/vagrant/.rvm/gems/ruby-2.5.1/gems/dynflow-1.2.0/lib/dynflow/middleware/stack.rb:26:in
  `pass'" 
- "/home/vagrant/.rvm/gems/ruby-2.5.1/gems/dynflow-1.2.0/lib/dynflow/middleware.rb:18:in
  `pass'" 

This doesn't seem to affect the actual sync.


Related issues

Related to Katello - Refactor #24878: Pulp repository service migration: Refresh/updateClosed
Is duplicate of Katello - Bug #25954: Capsule sync failed with undefined method `backend_service' for nil:NilClass after upgradeClosed

History

#1 Updated by Justin Sherrill 8 months ago

  • Related to Refactor #24878: Pulp repository service migration: Refresh/update added

#2 Updated by Andrew Kofink 8 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.10.1
  • Priority changed from Normal to High

#3 Updated by Jonathon Turel 6 months ago

  • Is duplicate of Bug #25954: Capsule sync failed with undefined method `backend_service' for nil:NilClass after upgrade added

#4 Updated by Jonathon Turel 6 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF