Project

General

Profile

Bug #25874

hammer docker manifest list never shows docker tag names

Added by Partha Aji about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
CLI
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

`hammer docker manifest list` has "Tag name" column, but never shows anything in it.

It seems that hammer_cli_foreman_docker/lib/hammer_cli_foreman_docker/docker_manifest.rb file expects tag field with definition of single tag. Meanwhile, API returns "tags" field with array of tags data.

git log on katello/app/models/katello/docker_manifest.rb shows that model used to have `has_one :docker_tag`, but that was changed to `has_many` in late 2016. Marking as Regression since I assume it did work as advertised before that change.

Associated revisions

Revision b12b9a0f (diff)
Added by Partha Aji about 4 years ago

Fixes #25874 - Shows tag info in manifest list

Prior to this commit "hammer docker manifest list" would show empty
values in the "Tag Names" column. This is because Tags became a one to
many. i.e. manifest can have multiple tags.

This commit addresses both the "docker manifest list" and "docker
manifest info" cases appropriately

History

#1 Updated by Partha Aji about 4 years ago

  • Bugzilla link set to 1658274

#2 Updated by Partha Aji about 4 years ago

  • Status changed from New to Closed

Also available in: Atom PDF