Project

General

Profile

Bug #25875

Repo filtering is inconsistent

Added by Jonathon Turel over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1654264

Description of problem:

When testing repos using a manifest created with the HTB SKU RH00076, only one RPM repo is displayed but many more are present in the manifest.

Version-Release number of selected component (if applicable):

candlepin-2.5.7-1.el7.noarch
Version 1.21.0-develop

How reproducible:

I repeated the test twice with a vagrant halt up cycle between them.

Steps to Reproduce:
1. Navigate to "Available Repositories"
2. Notice "Filter by Prodcut" is greyed out but "RPM" is bold because it is selected by default in the drop-down menu.

Actual results:

RPM is selected

Only this repo is displayed.
Red Hat Enterprise Linux Atomic Host HTB (RPMs)
rhel-atomic-host-htb-rpms

If you unselect RPM, then many more HTB repos are displayed, many of them RPM type (with default 20 per page it says: 1-20 of 186).

Selecting "Beta" appears to have no effect but selecting "Other" displays page 1-20 of 86 with default 20 per page view.

Expected results:

RPM should not be selected by default.

Selecting RPM should not prevent some, but not all, RPM repos from displaying.

Associated revisions

Revision 7d6135a6 (diff)
Added by Jonathon Turel about 2 years ago

Fixes #25875 - Improve Beta and HTB repos filtering

History

#1 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7929 added

#2 Updated by Anonymous about 2 years ago

  • Status changed from Ready For Testing to Closed

#3 Updated by John Mitsch about 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.12.0
  • Subject changed from Repo filtering is inconsistent to Repo filtering is inconsistent

Also available in: Atom PDF