Project

General

Profile

Bug #25917

Error When Creating or Editing Host Group With Operating System

Added by John Mitsch 10 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1658659

You can reproduce this by create a host group with an OS with no family

1. hammer architecture create --organization-id 1 --name 'reproducer_arch'
2. echo 'default ptable layout' > /tmp/ptable_layout
3. hammer partition-table create --organization-id 1 --name 'reproducer_ptable' --file /tmp/ptable_layout
4. hammer os create --major 7574 --name 'reproducer_os' --architecture-ids :arch_id --partition-table-ids :ptable_id
5. hammer hostgroup create --name 'reproducer_hostgroup' --architecture-id :arch_id --partition-table-id :ptable_id --operatingsystem-id :os_id


Related issues

Related to Katello - Bug #25379: Kickstart repo seems not available in promoted CV.Closed

Associated revisions

Revision ee4dbaba (diff)
Added by John Mitsch 10 months ago

Fixes #25917 - Check operating sys supports 'kickstart_repository'

  • Fixes #25917 - Check operatingsys supports 'kickstart_repository'
    before calling. Operating systems with no family won't have the
    'kickstart_repository' method since this is a method for RedHat
    class operating systems.

I'm not sure if this bug is a symptom of larger issues around
operating systems, but it does fix the issue and I've added a test
that reproduces the issue.

  • Refs #25917 - Change to use respond_to?

History

#1 Updated by The Foreman Bot 10 months ago

  • Assignee set to John Mitsch
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7943 added

#2 Updated by John Mitsch 10 months ago

  • Status changed from Ready For Testing to Closed

#3 Updated by Jonathon Turel 10 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.12.0
  • Subject changed from Error When Creating or Editing Host Group With Operating System to Error When Creating or Editing Host Group With Operating System

#4 Updated by Tomer Brisker 9 months ago

  • Related to Bug #25379: Kickstart repo seems not available in promoted CV. added

#5 Updated by Tomer Brisker 9 months ago

  • Triaged changed from Yes to No
  • Found in Releases Katello 3.10.0 added

Looks like this was introduced in 3.10 by #25379, and also breaks hostsgroups for all non-RH oses, a user just came in reporting xenserver is broken with:

Oops, we're sorry but something went wrong undefined method `kickstart_repos' for #<Xenserver:0x00007f418abd8b20>

Removing triage and proposing pulling this into 3.10.1 and 3.11.

#6 Updated by Jonathon Turel 9 months ago

  • Target version changed from Katello 3.12.0 to Katello 3.10.1

#7 Updated by Andrew Kofink 9 months ago

  • Triaged changed from No to Yes

Also available in: Atom PDF