Project

General

Profile

Bug #25925

admin cannot edit a user without re-entering the user's password

Added by Tomer Brisker over 1 year ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Users, Roles and Permissions
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

previously, iirc, the password fields were disabled by default and only editable when the field was explicitly enabled


Related issues

Related to Foreman - Refactor #21170: move password_strength.js file to webpackClosed2017-10-02

Associated revisions

Revision e134d3a8 (diff)
Added by Leos Stejskal 7 months ago

Fixes #25925 - Disable autocomplete for password input on User Edit page

History

#1 Updated by Tomer Brisker over 1 year ago

  • Priority changed from High to Normal

Looks like this is caused by autocomplete filling in the password field with the admin password, clearing the field removes the error.
The password fields on the user form should disable autocomplete.

#2 Updated by Tomer Brisker over 1 year ago

  • Related to Refactor #21170: move password_strength.js file to webpack added

#3 Updated by The Foreman Bot 9 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7375 added

#4 Updated by The Foreman Bot 7 months ago

  • Fixed in Releases 2.1.0 added

#5 Updated by Leos Stejskal 7 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Tomer Brisker 3 months ago

  • Category changed from 218 to Users, Roles and Permissions

Also available in: Atom PDF