Project

General

Profile

Bug #25949

Boolean false facts do not show up in the web UI

Added by Atanas Stoyanov almost 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hello team,

When viewing the facts for hosts on their facts page https://${foremanurl}/hosts/${host}/facts the facts with a value of boolean false do not show up, as if they are not defined at all. Boolean facts with value of true DO show up.
I have around 400 facts per host and the setting for my results per page is 500 so all facts are visible on the first page.

The same facts are displayed correctly if you do puppet facts find:

"is_libvirtd": false, <- Does not show up in foreman, also when queried via api.
"is_megaraid": true, <- Shows up
"is_nfsclient": "false", <- It is string, so it shows up.

We are running foreman version 1.19.0 and puppet 5.5.7

Kind Regards,
Atanas Stoyanov
intelliAd Media GmbH


Related issues

Is duplicate of Foreman - Bug #25483: Custom boolean facts with false value are not importedClosed

History

#1 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Is duplicate of Bug #25483: Custom boolean facts with false value are not imported added

#2 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Status changed from New to Duplicate

This is a duplicate of #25483 which has been merged and is part of 1.21.0

Also available in: Atom PDF