Project

General

Profile

Bug #25987

APIv4 | Creating VM results in creation of stateless desktop

Added by Arend Lapere over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources - oVirt
Target version:
Difficulty:
easy
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I've been grinding my teeth with this one. I've created a new oVirt Compute Resource and selected to use v4 API (experimental)... I know, it's experimental...

However, looking at oVirt it seems the VM is created as stateless desktop, which, as far as I can tell from reading up and testing this out, results in the VM's hard drive being reset to day 0. However, in the beginning there was no OS, meaning everything starts to fail and I had to redeploy my windows. Luckily I noticed this and could revert the setting; still, it shouldn't create a stateless anything as a default, IMO? Or am I missing the bigger picture here?


Related issues

Is duplicate of Foreman - Bug #24808: Updating Host cause the parameters Stateless,Start in Pause Mode and Delete Protection be checked.Closed

History

#1 Updated by Arend Lapere over 3 years ago

  • Description updated (diff)

#2 Updated by Tomer Brisker over 3 years ago

  • Related to Bug #24808: Updating Host cause the parameters Stateless,Start in Pause Mode and Delete Protection be checked. added

#3 Updated by Shira Maximov over 3 years ago

  • Is duplicate of Bug #24808: Updating Host cause the parameters Stateless,Start in Pause Mode and Delete Protection be checked. added

#4 Updated by Shira Maximov over 3 years ago

  • Status changed from New to Duplicate

#5 Updated by Shira Maximov over 3 years ago

  • Related to deleted (Bug #24808: Updating Host cause the parameters Stateless,Start in Pause Mode and Delete Protection be checked.)

Also available in: Atom PDF