Project

General

Profile

Bug #25990

Capsule details shows 'TFTP server: false' in services tab, when tftp_servername in proxy settings is not configured

Added by Ondřej Pražák over 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Category:
Smart Proxy
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
When tftp_servername is not set in the proxy module configuration, the services tab on capsule details shows 'TFTP server' false: this causes confusion, as it looks like that the tftp is not configured properly, which is not the case.

How reproducible:
100%

Steps to Reproduce:
1. installer satellite with tftp enabled
2. got to internal capsule details, service tab
3. see TFTP server: false

Actual results:
`TFTP server false`

Expected results:
Since we fallback to the proxy url as the next server, we should probably
show this info in the `TFTP server name` as well`


Related issues

Related to Smart Proxy - Bug #27896: Allow DHCP providers to accept filename option as hostnameClosed

Associated revisions

Revision 60c03b6a (diff)
Added by Lukáš Zapletal 6 months ago

Fixes #25990 - no reverse DNS search for bs (#6465)

History

#1 Updated by The Foreman Bot over 1 year ago

  • Assignee set to Lukas Zapletal
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6465 added

#2 Updated by Lukas Zapletal 8 months ago

  • Related to Bug #27896: Allow DHCP providers to accept filename option as hostname added

#3 Updated by The Foreman Bot 6 months ago

  • Fixed in Releases 2.0.0 added

#4 Updated by Anonymous 6 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF