Project

General

Profile

Bug #26014

Html numeric code is displayed on task page

Added by Ivan Necas 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1670524

Description of problem:

Task page displays html numeric code rather showing characters.

Ex:
manifest import task shows

Import Manifest organization 'TmCzDiMvfhZI'

It should show

Import Manifest organization 'TmCzDiMvfhZI'

Version-Release number of selected component (if applicable):
Satellite 6.5 snap13

How reproducible: always

Steps to Reproduce:
1. Navigate to Monitor -> tasks page
2. See any task name having the special character in name such as import manifest task

Actual results:
task name displayed with Html numeric code

Expected results:

No Html numeric code in task name on tasks page.

Additional info:


Related issues

Related to Foreman - Bug #25503: Breadcrumb show allow truncation with full title in tooltip on mouse hoverClosed
Has duplicate foreman-tasks - Bug #25418: HTML entities visible on task details pageDuplicate

Associated revisions

Revision 1bb99cb4 (diff)
Added by Ivan Necas 5 months ago

Fixes #26014 - don't use Rails truncate in breadcrumb

The truncation does additional html escaping that doesn't work well
will JS's one. Since https://projects.theforeman.org/issues/25503, we
don't need to do explicit truncation in breadrumbs anymore, so we can
just get rid of it.

History

#1 Updated by The Foreman Bot 5 months ago

  • Assignee set to Ivan Necas
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-tasks/pull/389 added

#2 Updated by Ivan Necas 5 months ago

  • Related to Bug #25503: Breadcrumb show allow truncation with full title in tooltip on mouse hover added

#3 Updated by Ivan Necas 5 months ago

  • Status changed from Ready For Testing to Closed
  • Subject changed from Html numeric code is displayed on task page to Html numeric code is displayed on task page

#4 Updated by Mirosław Zalewski 5 months ago

  • Related to Bug #25418: HTML entities visible on task details page added

#5 Updated by Mirosław Zalewski 5 months ago

  • Related to deleted (Bug #25418: HTML entities visible on task details page)

#6 Updated by Mirosław Zalewski 5 months ago

  • Has duplicate Bug #25418: HTML entities visible on task details page added

Also available in: Atom PDF