Project

General

Profile

Bug #26029

error message have wrong links: Failure parsing Kickstart default PXELinux: undefined method `full_path' for nil:NilClass.

Added by Ivan Necas 10 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Unattended installations
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1664296

Description of problem:
Links to templates on host build failure lead to 404.

Steps to Reproduce:
1. Setup a provisioning template that produces an error
2. In managed host details, click build
3. The popup shows info about the failed template, with links to edit the template

Action result:

The link looks like this:

https://foreman.example.com/templates/provisioning_templates/Kickstart%20default%20PXELinux/edit

Expected results:

The link looks like this:

https://foreman.example.com/templates/provisioning_templates/14-Kickstart%20default%20PXELinux/edit

Associated revisions

Revision 318bd70a (diff)
Added by Ivan Necas 9 months ago

Fixes #26029 - correct links to templates on build failure (#6477)

History

#1 Updated by The Foreman Bot 10 months ago

  • Assignee set to Ivan Necas
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6477 added

#2 Updated by Marek Hulán 9 months ago

  • Subject changed from error message have wrong links: Failure parsing Kickstart default PXELinux: undefined method `full_path' for nil:NilClass. [Edit] to error message have wrong links: Failure parsing Kickstart default PXELinux: undefined method `full_path' for nil:NilClass. [Edit]
  • Fixed in Releases 1.22.0 added

#3 Updated by Anonymous 9 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Tomer Brisker 6 months ago

  • Subject changed from error message have wrong links: Failure parsing Kickstart default PXELinux: undefined method `full_path' for nil:NilClass. [Edit] to error message have wrong links: Failure parsing Kickstart default PXELinux: undefined method `full_path' for nil:NilClass.

Also available in: Atom PDF