Project

General

Profile

Bug #26159

ActivationKey Repository Sets show "old" name of repository

Added by Markus Bucher 4 months ago. Updated 7 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Activation Key
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Not sure if this is a bug:
When I change the name of a Product's Repository, the change is not reflected in the Repository-Sets tab of the Activation-Key.

Reproducable by:
  1. Add Product named "P1" with Repository named "R1"
  2. Create ContentView, add R1 to it, create new CV-Version and promote it to a Lifecycle Env.
  3. Create ActivationKey pointing to the created ContentView
  4. Repository-Sets Tab of the Activation Key will show "Repository-Name=R1" and "Product=P1"
  5. Change name of Repository to "R2"

Expected:
Repository-Sets tab of the Activation Key should show "Repository-Name=R2"

Actual:
Repository-Set tab still shows "Repository-Name=R1", which can make it quite confusing

I understand this is because the Repository Sets tab shows objects of model-class Katello::Content and not Katello::Repository(Root).
Katello::Content having its own name-field, which is not automatically updated if repository-name changes.

Associated revisions

Revision 660fec0f (diff)
Added by Samir Jha 7 days ago

Fixes #26159 - Activation Key Repository set label

History

#1 Updated by Quirin Pamp 4 months ago

I would say that this is definitely a bug from the users point of view.

#2 Updated by Andrew Kofink 4 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello Backlog

#3 Updated by Brad Buckingham about 2 months ago

The root cause for this one may be similar as the cause for: https://projects.theforeman.org/issues/26466

#4 Updated by Samir Jha 13 days ago

  • Category set to Activation Key

#5 Updated by The Foreman Bot 13 days ago

  • Assignee set to Samir Jha
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8146 added

#6 Updated by Anonymous 7 days ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF