Project

General

Profile

Bug #26168

Ovirt client returned an error: undefined method `href' for nil:NilClass

Added by Ori Rabin over 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - oVirt
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1679593

Description of problem:
When using APIv4, host creatin always fails with "Failed to create a compute rhev4 (RHV) instance ramon-rozycki.testdom: Ovirt client returned an error: undefined method `href' for nil:NilClass"

Version-Release number of selected component (if applicable):
Reproduced on Sat 6.5 snap 15. It worked in some previous snap.

How reproducible:
Deterministic.

Steps to Reproduce:
1. Have a RHEV, add it as a CR to Satellite using APIv4
2. Hosts -> Create host -> fill -> submit

Actual results:
Failure

"Failed to create a compute rhev4 (RHV) instance ramon-rozycki.testdom: Ovirt client returned an error: undefined method `href' for nil:NilClass"

Traceback (attached)

Expected results:
Successfully created Host and VM


Related issues

Is duplicate of Foreman - Bug #25276: "undefined method `href' for nil:NilClass" when provisioning host without --interfaceClosed

Associated revisions

Revision cd8d9444 (diff)
Added by Shira Maximov 9 months ago

Fixes #26168,#25276 - Create ovirt interface/volume if not empty

History

#1 Updated by Ori Rabin over 1 year ago

  • Assignee set to Ori Rabin
  • Status changed from New to Assigned

#2 Updated by Ori Rabin over 1 year ago

  • Status changed from Assigned to Duplicate

#3 Updated by Ori Rabin over 1 year ago

  • Is duplicate of Bug #25276: "undefined method `href' for nil:NilClass" when provisioning host without --interface added

#4 Updated by The Foreman Bot 9 months ago

  • Fixed in Releases 1.24.0 added

#5 Updated by Tomer Brisker 9 months ago

  • Status changed from Duplicate to Closed

Also available in: Atom PDF