Project

General

Profile

Bug #26188

katello-ssl-tool fails on nightly

Added by Evgeni Golov about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

    [[31mERROR[0m [34m2019-02-28T10:51:34[0m [36mverbose[0m]  Execution of '/bin/katello-ssl-tool --gen-ca -p file:/etc/pki/katello/private/katello-default-ca.pwd --force --ca-cert-dir /etc/pki/katello-certs-tools/certs --set-common-name pipeline-luna-nightly-centos7.kangae.example.com --ca-cert katello-default-ca.crt --ca-key katello-default-ca.key --ca-cert-rpm katello-default-ca --set-country US --set-state North Carolina --set-city Raleigh --set-org Katello --set-org-unit SomeOrgUnit --set-email  --cert-expiration 36500' returned 2: Unknown option: -
    [[31mERROR[0m [34m2019-02-28T10:51:34[0m [36mverbose[0m] usage: /usr/bin/python2 [option] ... [-c cmd | -m mod | file | -] [arg] ...
    [[31mERROR[0m [34m2019-02-28T10:51:34[0m [36mverbose[0m] Try `python -h' for more information.

That's with katello-certs-tools-2.5.0-1.el7.noarch

Associated revisions

Revision 9bc26ad2 (diff)
Added by Evgeni Golov about 3 years ago

Refs #26188 - drop shebang from katello_ssl_tool.py

it's not meant to be called directly

History

#1 Updated by Evgeni Golov about 3 years ago

The issue is it generated a wrong shebang:

#!/usr/bin/python2 -s -s

The second -s is too much.

#2 Updated by Evgeni Golov about 3 years ago

from the koji log:

+ pathfix.py -pni '/usr/bin/python2 -s' . katello-ssl-tool
…
+ /usr/bin/python2 setup.py build '--executable=/usr/bin/python2 -s'

this seems to generate the doubled -s

#3 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-packaging/pull/3477 added

#4 Updated by Evgeni Golov about 3 years ago

  • Status changed from Ready For Testing to Closed

#5 Updated by John Mitsch about 3 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.12.0
  • Category set to Installer

Also available in: Atom PDF