Project

General

Profile

Bug #26193

foreman-rake command throw lot of Warning messages while running any rake commands

Added by John Mitsch over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Rake tasks
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1674496

Description of problem:

Here is the output while running foreman-rake console command:

  1. foreman-rake console
    /usr/share/foreman/lib/foreman.rb:8: warning: already initialized constant Foreman::UUID_REGEXP
    /usr/share/foreman/lib/foreman.rb:8: warning: previous definition of UUID_REGEXP was here
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/content_facet_host_extensions.rb:7: warning: already initialized constant Katello::Concerns::ContentFacetHostExtensions::ERRATA_STATUS_MAP
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/content_facet_host_extensions.rb:7: warning: previous definition of ERRATA_STATUS_MAP was here
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/content_facet_host_extensions.rb:14: warning: already initialized constant Katello::Concerns::ContentFacetHostExtensions::TRACE_STATUS_MAP
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/content_facet_host_extensions.rb:14: warning: previous definition of TRACE_STATUS_MAP was here
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:13: warning: already initialized constant Katello::Concerns::SubscriptionFacetHostExtensions::SUBSCRIPTION_STATUS_MAP
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:13: warning: previous definition of SUBSCRIPTION_STATUS_MAP was here
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:21: warning: already initialized constant Katello::Concerns::SubscriptionFacetHostExtensions::SLA_STATUS_MAP
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:21: warning: previous definition of SLA_STATUS_MAP was here
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:26: warning: already initialized constant Katello::Concerns::SubscriptionFacetHostExtensions::USAGE_STATUS_MAP
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:26: warning: previous definition of USAGE_STATUS_MAP was here
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:31: warning: already initialized constant Katello::Concerns::SubscriptionFacetHostExtensions::ROLE_STATUS_MAP
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:31: warning: previous definition of ROLE_STATUS_MAP was here
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:36: warning: already initialized constant Katello::Concerns::SubscriptionFacetHostExtensions::ADDONS_STATUS_MAP
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:36: warning: previous definition of ADDONS_STATUS_MAP was here
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:41: warning: already initialized constant Katello::Concerns::SubscriptionFacetHostExtensions::PURPOSE_STATUS_MAP
    /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.19/app/models/katello/concerns/subscription_facet_host_extensions.rb:41: warning: previous definition of PURPOSE_STATUS_MAP was here
    Loading production environment (Rails 5.2.1)
    Failed to load console gems, starting anyway
    irb(main):001:0>

The same output is seen while running any command using foreman-rake.

Version-Release number of selected component (if applicable):
Satellite 6.5 SNAP 15

How reproducible:
Always

Steps to Reproduce:
1. Install Satellite 6.5 and run # foreman-rake console or # foreman-rake permissions:reset
2.
3.

Actual results:
Throws lot of Warning messages on the console.

Expected results:
There should not be any warning messages.

Additional info:


Related issues

Is duplicate of Foreman - Bug #26194: foreman-rake command throw lot of Warning messages while running any rake commandsClosed

History

#1 Updated by Tomer Brisker over 2 years ago

  • Status changed from New to Duplicate

Looks like this was cloned twice from bz.

#2 Updated by Tomer Brisker over 2 years ago

  • Is duplicate of Bug #26194: foreman-rake command throw lot of Warning messages while running any rake commands added

Also available in: Atom PDF