Project

General

Profile

Bug #26233

katello nightly not installable because of "Puppet 4.10.12 does not meet requirements for puppet-squid (>= 5.5.8 < 7.0.0)"

Added by Jan Hutaƙ about 1 year ago. Updated 12 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
External (Puppet Labs) modules
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

[root@katello ~]# foreman-installer --scenario katello --enable-foreman-proxy-plugin-remote-execution-ssh
Puppet 4.10.12 does not meet requirements for puppet-squid (>= 5.5.8 < 7.0.0)
Cannot continue due to incompatible version of Puppet. Use --skip-puppet-version-check to disable this check.

I know there is https://projects.theforeman.org/issues/22746, but looks like nightly packages were not build yet (and PR was merged some time ago).


Related issues

Related to Packaging - Refactor #26339: Require at least Puppet 5.5.8Closed

History

#1 Updated by Ewoud Kohl van Wijngaarden about 1 year ago

  • Category set to External (Puppet Labs) modules
  • Found in Releases 1.22.0 added

Because of this https://community.theforeman.org/t/dropping-puppet-4-support-in-our-installer/13029 was opened. I'm strongly leaning to dropping Puppet 4 support in nightly, especially considering it's EOL upstream.

#2 Updated by Ewoud Kohl van Wijngaarden about 1 year ago

#3 Updated by Ewoud Kohl van Wijngaarden 12 months ago

  • Status changed from New to Duplicate

Going to consider this a duplicate of #26339.

Also available in: Atom PDF