Project

General

Profile

Bug #26256

foreman-proxy-certs-generate doesn't give the install command

Added by John Mitsch 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Category:
foreman-installer script
Target version:
Difficulty:
Triaged:
No
Bugzilla link:

Description

Found on a devel box with:
foreman-installer-1.22.0-0.2.develop.20190306031555git3bd5f42.el7.noarch
foreman-installer-katello-1.22.0-0.2.develop.20190306031555git3bd5f42.el7.noarch

I don't see a message outputting the install command for the foreman-proxy when running `foreman-proxy-certs-generate`

[root@centos7-devel katello{master}]$ foreman-proxy-certs-generate --foreman-proxy-fqdn "centos7-proxy-devel.jomitsch.example.com" --certs-tar "~/centos7-proxy-devel.jomitsch.example.com-certs.tar"
Installing Done [100%] [...............................................................................................................]

Associated revisions

Revision 04409b92 (diff)
Added by Ewoud Kohl van Wijngaarden 8 months ago

Fixes #26256 - Fix proxy cert generation hooks

When merging the installers, the hooks were removed from the certificate
generation process because most hooks are irrelevant. Not all, so this
caused a regression.

Rather than enabling all hooks again, this takes the more minimal route
of only adding the relevant hooks.

History

#1 Updated by Ewoud Kohl van Wijngaarden 8 months ago

  • Target version set to 1.22.0
  • Category changed from Installer to foreman-installer script
  • Project changed from Katello to Installer
  • Found in Releases 1.21.0, 1.22.0 added

I believe this will require a new foreman-installer 1.21 release with the bugfix for Katello 3.11.

#2 Updated by The Foreman Bot 8 months ago

  • Assignee set to Ewoud Kohl van Wijngaarden
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-installer/pull/324 added

#3 Updated by Ewoud Kohl van Wijngaarden 8 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Sven Vogel 8 months ago

i can confirm this problem in 1.2.1 with katello.

#5 Updated by Ewoud Kohl van Wijngaarden 8 months ago

  • Fixed in Releases 1.21.1, 1.22.0 added

Thanks for reminding me. Would have missed the cherry pick to 1.21.1 otherwise, but that's now done.

Also available in: Atom PDF