Project

General

Profile

Bug #26332

nightly installation error: /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[katello.nodhcp.local]/ensure: change from absent to present failed: Proxy katello.nodhcp.local has failed to load one or more features (HTTPBoot, Puppet, Puppet C

Added by Jan Hutaƙ about 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I'm getting:

```
[root@katello ~]# foreman-installer --scenario katello --skip-puppet-version-check --enable-foreman-cli-remote-execution --enable-foreman-plugin-remote-execution --enable-foreman-proxy-plugin-remote-execution-ssh
Proxy katello.nodhcp.local has failed to load one or more features (HTTPBoot, Puppet, Puppet CA, TFTP, Templates, Logs, Dynflow), check /var/log/foreman-proxy/proxy.log for configuration errors
/usr/share/foreman-installer/modules/foreman/lib/puppet/provider/foreman_smartproxy/rest_v3.rb:70:in `validate_features!'
/usr/share/foreman-installer/modules/foreman/lib/puppet/provider/foreman_smartproxy/rest_v3.rb:24:in `create'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/property/ensure.rb:16:in `block in defaultvalues'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/property.rb:487:in `set'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/property.rb:561:in `sync'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:236:in `sync'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:134:in `sync_if_needed'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:80:in `perform_changes'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:21:in `evaluate'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction.rb:233:in `apply'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction.rb:249:in `eval_resource'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction.rb:163:in `call'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction.rb:163:in `block (2 levels) in evaluate'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:507:in `block in thinmark'
/opt/puppetlabs/puppet/lib/ruby/2.1.0/benchmark.rb:294:in `realtime'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:506:in `thinmark'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction.rb:163:in `block in evaluate'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/graph/relationship_graph.rb:118:in `traverse'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction.rb:154:in `evaluate'
/usr/share/gems/gems/kafo-2.1.0/modules/kafo_configure/lib/puppet/parser/functions/add_progress.rb:30:in `evaluate_with_trigger'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:222:in `block in apply'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util/log.rb:155:in `with_destination'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/report.rb:146:in `as_logging_destination'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:221:in `apply'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/configurer.rb:171:in `block in apply_catalog'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:224:in `block in benchmark'
/opt/puppetlabs/puppet/lib/ruby/2.1.0/benchmark.rb:294:in `realtime'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:223:in `benchmark'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/configurer.rb:170:in `apply_catalog'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/configurer.rb:343:in `run_internal'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/configurer.rb:221:in `block in run'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/context.rb:65:in `override'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet.rb:306:in `override'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/configurer.rb:195:in `run'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application/apply.rb:348:in `apply_catalog'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application/apply.rb:274:in `block in main'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/context.rb:65:in `override'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet.rb:306:in `override'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application/apply.rb:225:in `main'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application/apply.rb:170:in `run_command'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application.rb:375:in `block in run'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:662:in `exit_on_fail'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application.rb:375:in `run'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util/command_line.rb:132:in `run'
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util/command_line.rb:72:in `execute'
/opt/puppetlabs/puppet/bin/puppet:5:in `<main>'
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[katello.nodhcp.local]/ensure: change from absent to present failed: Proxy katello.nodhcp.local has failed to load one or more features (HTTPBoot, Puppet, Puppet CA, TFTP, Templates, Logs, Dynflow), check /var/log/foreman-proxy/proxy.log for configuration errors
Installing Done [100%] [...........................................................................................................................................................]
Something went wrong! Check the log for ERROR-level output
The full log is at /var/log/foreman-installer/katello.log
yum install -y -q rh-mongodb34-syspaths finished successfully!
[root@katello ~]# yum repolist | tee
Loaded plugins: product-id, search-disabled-repos, subscription-manager
repo id repo name status
centos-sclo-rh/x86_64 CentOS-7 - SCLo rh 8,113
*epel/x86_64 Extra Packages for Enterprise 12,974
foreman/x86_64 Foreman nightly 491
foreman-plugins/x86_64 Foreman plugins nightly 1,831
foreman-rails/x86_64 Rails SCL for Foreman nightly 59
katello/x86_64 Katello Nightly 37
katello-candlepin/x86_64 Candlepin: an open source enti 3
pulp/7Server/x86_64 Pulp Community Release 67
puppetlabs-pc1/x86_64 Puppet Labs PC1 Repository el 187
rhel-7-server-extras-rpms/x86_64 Red Hat Enterprise Linux 7 Ser 1,076
rhel-7-server-optional-rpms/7Server/x86_64 Red Hat Enterprise Linux 7 Ser 17,422
rhel-7-server-rpms/7Server/x86_64 Red Hat Enterprise Linux 7 Ser 23,723
repolist: 65,983
```

I do not see anything interesting in the log error message suggests:

```
[root@katello ~]# grep '^2019' /var/log/foreman-proxy/proxy.log | grep -v '\[I\]'
...no output...
```

Packages are:

```
[root@katello ~]# rpm -qa | grep -e foreman -e katello | sort
foreman-1.22.0-0.6.develop.20190312103025git0356709.el7.noarch
foreman-cli-1.22.0-0.6.develop.20190312103025git0356709.el7.noarch
foreman-compute-1.22.0-0.6.develop.20190312103025git0356709.el7.noarch
foreman-debug-1.22.0-0.6.develop.20190312103025git0356709.el7.noarch
foreman-installer-1.22.0-0.2.develop.20190312202849git09a8a3b.el7.noarch
foreman-installer-katello-1.22.0-0.2.develop.20190312202849git09a8a3b.el7.noarch
foreman-postgresql-1.22.0-0.6.develop.20190312103025git0356709.el7.noarch
foreman-proxy-1.22.0-0.1.develop.20190308154738git21642e6.el7.noarch
foreman-release-1.22.0-0.1.develop.el7.noarch
foreman-release-scl-7-2.el7.noarch
foreman-selinux-1.22.0-0.1.develop.20190312202305gitedd291b.el7.noarch
katello-3.12.0-0.3.master.el7.noarch
katello-certs-tools-2.5.3-1.el7.noarch
katello-client-bootstrap-1.7.0-1.el7.noarch
katello-common-3.12.0-0.3.master.el7.noarch
katello-debug-3.12.0-0.3.master.el7.noarch
katello-default-ca-1.0-1.noarch
katello.nodhcp.local-apache-1.0-1.noarch
katello.nodhcp.local-foreman-client-1.0-1.noarch
katello.nodhcp.local-foreman-proxy-1.0-1.noarch
katello.nodhcp.local-foreman-proxy-client-1.0-1.noarch
katello.nodhcp.local-puppet-client-1.0-1.noarch
katello.nodhcp.local-qpid-broker-1.0-1.noarch
katello.nodhcp.local-qpid-client-cert-1.0-1.noarch
katello.nodhcp.local-qpid-router-client-1.0-1.noarch
katello.nodhcp.local-qpid-router-server-1.0-1.noarch
katello.nodhcp.local-tomcat-1.0-1.noarch
katello-repos-3.12.0-0.1.nightly.el7.noarch
katello-selinux-3.0.3-1.el7.noarch
katello-server-ca-1.0-1.noarch
katello-service-3.12.0-0.3.master.el7.noarch
pulp-katello-1.0.2-1.el7.noarch
rubygem-foreman_maintain-0.4.1-1.el7.noarch
tfm-rubygem-foreman_docker-4.1.1-1.fm1_22.el7.noarch
tfm-rubygem-foreman_remote_execution-1.7.0-7.fm1_22.el7.noarch
tfm-rubygem-foreman_remote_execution_core-1.1.5-1.el7.noarch
tfm-rubygem-foreman-tasks-0.15.0-2.fm1_22.el7.noarch
tfm-rubygem-foreman-tasks-core-0.3.0-1.fm1_22.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.17-0.1.pre.develop.20190305102907git526f5f7.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-7.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.4-4.el7.noarch
tfm-rubygem-hammer_cli_foreman_remote_execution-0.1.0-2.fm1_20.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.13-1.fm1_20.el7.noarch
tfm-rubygem-hammer_cli_katello-0.18-0.1.pre.master.20190306155258git1abe582.el7.noarch
tfm-rubygem-katello-3.12.0-0.3.pre.master.20190306155258git9067e37.el7.noarch
```


Related issues

Is duplicate of Foreman - Bug #26331: smart proxy v2 create api returns empty feature listClosed

History

#1 Updated by Justin Sherrill about 1 year ago

  • Is duplicate of Bug #26331: smart proxy v2 create api returns empty feature list added

#2 Updated by Justin Sherrill about 1 year ago

  • Status changed from New to Duplicate
  • Category deleted (Installer)
  • Subject changed from katello nightly installation error: /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[katello.nodhcp.local]/ensure: change from absent to present failed: Proxy katello.nodhcp.local has failed to load one or more features (HTTPBoot, Puppet, Puppet C to nightly installation error: /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[katello.nodhcp.local]/ensure: change from absent to present failed: Proxy katello.nodhcp.local has failed to load one or more features (HTTPBoot, Puppet, Puppet C
  • Project changed from Katello to Foreman

Also available in: Atom PDF