Project

General

Profile

Bug #26338

HTTP UEFI boot PXE loader use wrong smart proxy port

Added by Lukas Zapletal 9 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Unattended installations
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

No matter if user select HTTP or HTTPS, the port under the smart-proxy was registered is always used. This can match HTTP or HTTPS or not. Port numbers could be exposed by proxy (#26336) and this could be used in core.


Related issues

Related to Smart Proxy - Feature #26336: Expose HTTP and HTTPS port numbersNew
Related to Foreman - Tracker #26337: Improve HTTP Boot featureNew

Related to Smart Proxy - Bug #27654: Expose http(s) port number setting via httpboot pluginClosed

Associated revisions

Revision 165950eb (diff)
Added by Lukáš Zapletal about 2 months ago

Fixes #26338 - use port from HTTP boot feature (#6983)

History

#1 Updated by Lukas Zapletal 9 months ago

#2 Updated by Lukas Zapletal 9 months ago

#3 Updated by Lukas Zapletal 4 months ago

  • Related to Bug #27654: Expose http(s) port number setting via httpboot plugin added

#4 Updated by The Foreman Bot 4 months ago

  • Assignee set to Lukas Zapletal
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6983 added

#5 Updated by The Foreman Bot about 2 months ago

  • Fixed in Releases 1.24.0 added

#6 Updated by Anonymous about 2 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF