Project

General

Profile

Refactor #26339

Require at least Puppet 5.5.8

Added by Ewoud Kohl van Wijngaarden 5 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
RPMs
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

This is the lowest version that satisfies the minimum Puppet version in our modules' metadata.json. Older versions will throw warnings. It's better to hard require the correct version. Puppet 4 is also EOL.

Follows from the RFC at https://community.theforeman.org/t/dropping-puppet-4-support-in-our-installer/13029


Related issues

Related to Installer - Bug #26233: katello nightly not installable because of "Puppet 4.10.12 does not meet requirements for puppet-squid (>= 5.5.8 < 7.0.0)"Duplicate
Copied to Packaging - Refactor #26340: Require at least Puppet 5.5.8Closed

Associated revisions

Revision a87c4174 (diff)
Added by Ewoud Kohl van Wijngaarden 5 months ago

Fixes #26339 - Update foreman-installer dependencies

History

#1 Updated by Ewoud Kohl van Wijngaarden 5 months ago

  • Related to Bug #26233: katello nightly not installable because of "Puppet 4.10.12 does not meet requirements for puppet-squid (>= 5.5.8 < 7.0.0)" added

#2 Updated by Ewoud Kohl van Wijngaarden 5 months ago

#3 Updated by The Foreman Bot 5 months ago

  • Assignee set to Ewoud Kohl van Wijngaarden
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-packaging/pull/3500 added

#4 Updated by Ewoud Kohl van Wijngaarden 5 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Tomer Brisker 3 months ago

  • Fixed in Releases 1.22.0 added

Also available in: Atom PDF