Project

General

Profile

Refactor #26340

Require at least Puppet 5.5.8

Added by Ewoud Kohl van Wijngaarden 7 months ago.

Status:
Closed
Priority:
Normal
Category:
Debian/Ubuntu
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

This is the lowest version that satisfies the minimum Puppet version in our modules' metadata.json. Older versions will throw warnings. It's better to hard require the correct version. Puppet 4 is also EOL.

Follows from the RFC at https://community.theforeman.org/t/dropping-puppet-4-support-in-our-installer/13029


Related issues

Copied from Packaging - Refactor #26339: Require at least Puppet 5.5.8Closed

Associated revisions

Revision 6cf652f8 (diff)
Added by Ewoud Kohl van Wijngaarden 7 months ago

Update foreman-installer dependencies

We now depend on kafo >= 3.0.0 and Puppet 5.5.8.

History

#1 Updated by Ewoud Kohl van Wijngaarden 7 months ago

Also available in: Atom PDF