Project

General

Profile

Bug #26390

React Snapshot test errors

Added by Justin Sherrill over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Tests
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Summary of all failing tests

FAIL webpack/scenes/Subscriptions/components/SubscriptionsTable/__tests__/SubscriptionTypeFormatter.test.js

  ● subscriptionTypeFormatter › renders link to a host

    expect(value).toMatchSnapshot()

    Received value does not match stored snapshot "subscriptionTypeFormatter renders link to a host 1".

    - Snapshot

    + Received

    @@ -1,11 +1,10 @@

      <td>

        <span>

          Guests of

          <Link

    -       replace={false}

            to="/content_hosts/83/" 

          >

            host.example.com

          </Link>

        </span>

      29 |     const formatter = subscriptionTypeFormatter(null, data({ hypervisor: { name: 'host.example.com', id: 83 } }));

      30 | 

    > 31 |     expect(toJson(shallow(formatter))).toMatchSnapshot();

         |                                        ^

      32 |   });

      33 | });

      34 | 

      at toMatchSnapshot (webpack/scenes/Subscriptions/components/SubscriptionsTable/__tests__/SubscriptionTypeFormatter.test.js:31:40)

      at tryCatch (node_modules/regenerator-runtime/runtime.js:62:40)

      at GeneratorFunctionPrototype.invoke [as _invoke] (node_modules/regenerator-runtime/runtime.js:288:22)

      at GeneratorFunctionPrototype.prototype.(anonymous function) [as next] (node_modules/regenerator-runtime/runtime.js:114:21)

      at step (webpack/scenes/Subscriptions/components/SubscriptionsTable/__tests__/SubscriptionTypeFormatter.test.js:13:191)

      at webpack/scenes/Subscriptions/components/SubscriptionsTable/__tests__/SubscriptionTypeFormatter.test.js:13:437

      at Object.<anonymous> (webpack/scenes/Subscriptions/components/SubscriptionsTable/__tests__/SubscriptionTypeFormatter.test.js:13:99)


Related issues

Is duplicate of Katello - Refactor #25912: Migrate js test-helpers to npm react-redux-test-utilsClosed

History

#1 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8026 added

#2 Updated by Evgeni Golov over 2 years ago

  • Bugzilla link set to 1690002

#3 Updated by Jonathon Turel over 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.12.0
  • Status changed from Ready For Testing to Duplicate

#4 Updated by Jonathon Turel over 2 years ago

  • Is duplicate of Refactor #25912: Migrate js test-helpers to npm react-redux-test-utils added

Also available in: Atom PDF