Project

General

Profile

Bug #26392

Location is not applied on users if all-users is checked

Added by Dor Pinhas 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Organizations and Locations
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Hello,

I just upgraded Foreman to latest, 1.21 and noticed Locations needs to be used.
After checked the checkbox 'All users' inside a location settings, users couldn't see the location.
Under the location box in users- location tab, the location wasn't on the "selected items" box.

Once removed the checkbox 'All users' the location appeared on the "selected items" box in a user settings.

Associated revisions

Revision 9bd4fac1 (diff)
Added by Tomer Brisker 3 months ago

Fixes #26392 - Include "all users" taxonomies in my_taxonomy

Otherwise, when selecting all users, users will not be able to set the
default taxonomy to such taxonomy, nor will other methods of
authentication would function correctly.

History

#1 Updated by Dor Pinhas 3 months ago

  • Fixed in Releases deleted (1.21.1)

#2 Updated by Tomer Brisker 3 months ago

  • Category set to Organizations and Locations

#3 Updated by The Foreman Bot 3 months ago

  • Assignee set to Tomer Brisker
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6588 added

#4 Updated by Ondřej Pražák 3 months ago

  • Status changed from Ready For Testing to Closed
  • Fixed in Releases 1.22.0 added

Also available in: Atom PDF