Project

General

Profile

Actions

Bug #26394

closed

when changing location user looses all navigation menus

Added by Joseph Boyer almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

using foreman 1.21.0 and Katello 3.11 change location causes all navigation menus to disappear

Here is the error that is seen in firefox's dev console.

TypeError: "a.locations.available_locations.find(...) is undefined"

value Layout.js:38 Wi8React
n i18nProviderWrapperFactory.js:18 i es6.promise.js:66 O es6.promise.js:83 c _microtask.js:18

react-dom.production.min.js:187:139

Lo12React
n i18nProviderWrapperFactory.js:18 i es6.promise.js:66 O es6.promise.js:83 c _microtask.js:18

Unhandled promise rejection TypeError: "a.locations.available_locations.find(...) is undefined"

value Layout.js:38 Wi8React
n i18nProviderWrapperFactory.js:18 i es6.promise.js:66 O es6.promise.js:83 c _microtask.js:18

es6.promise.js:101

t es6.promise.js:101 exports _perform.js:3 P es6.promise.js:95 exports _invoke.js:5 <anonymous> _task.js:35 y _task.js:21 v _task.js:25

Files

Screenshot 2019-03-21 at 18.18.07.png View Screenshot 2019-03-21 at 18.18.07.png 1.38 MB screen-shot-of-error-and_firefox-console Joseph Boyer, 03/21/2019 10:19 PM

Related issues 1 (0 open1 closed)

Related to Foreman - Task #23445: Change vertical menu to react implementationClosedGilad LeknerActions
Actions #1

Updated by Tomer Brisker almost 5 years ago

  • Related to Task #23445: Change vertical menu to react implementation added
Actions #2

Updated by Tomer Brisker almost 5 years ago

  • Category set to Web Interface
  • Target version set to 1.21.1
Actions #3

Updated by Tomer Brisker almost 5 years ago

  • Priority changed from Normal to High
Actions #4

Updated by Walden Raines almost 5 years ago

  • Assignee set to Gilad Lekner
Actions #5

Updated by Gilad Lekner almost 5 years ago

Joseph Boyer wrote:

using foreman 1.21.0 and Katello 3.11 change location causes all navigation menus to disappear

Here is the error that is seen in firefox's dev console.

TypeError: "a.locations.available_locations.find(...) is undefined"

value Layout.js:38 Wi8React

n i18nProviderWrapperFactory.js:18 i es6.promise.js:66 O es6.promise.js:83 c _microtask.js:18

react-dom.production.min.js:187:139

Lo12React

n i18nProviderWrapperFactory.js:18 i es6.promise.js:66 O es6.promise.js:83 c _microtask.js:18

Unhandled promise rejection TypeError: "a.locations.available_locations.find(...) is undefined"

value Layout.js:38 Wi8React

n i18nProviderWrapperFactory.js:18 i es6.promise.js:66 O es6.promise.js:83 c _microtask.js:18

es6.promise.js:101

t es6.promise.js:101 exports _perform.js:3 P es6.promise.js:95 exports _invoke.js:5 <anonymous> _task.js:35 y _task.js:21 v _task.js:25

Using 1.21 and 3.11 on Katello, can't seem to reproduce this bug. any specific steps?

Actions #6

Updated by Walden Raines almost 5 years ago

  • Status changed from New to Need more information
Actions #8

Updated by Gilad Lekner almost 5 years ago

File Screenshot 2019-03-21 at 18.18.07.png Screenshot 2019-03-21 at 18.18.07.pngScreenshot 2019-03-21 at 18.18.07.png added

Hi Joseph, Can you please provide a Video of reproducing this? Also which version of firefox are you using?
I can't reproduce this bug right now, using 1.21, 3.11.0 and Firefox 66.0.1

Actions #9

Updated by The Foreman Bot almost 5 years ago

  • Status changed from Need more information to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6613 added
Actions #10

Updated by Tomer Brisker almost 5 years ago

  • Fixed in Releases 1.20.3, 1.21.1, 1.22.0 added
Actions #11

Updated by Anonymous almost 5 years ago

  • Status changed from Ready For Testing to Closed
Actions

Also available in: Atom PDF