Project

General

Profile

Bug #26402

vmware compute-attributes scsi_controller_type not honored

Added by Marek Hulán 9 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - VMware
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
Creating a vmware host with the compute-attributes scsi_controller_type is not creating the VM with the provided SCSI controller type

Version-Release number of selected component (if applicable):

vSphere 6.5
hammer (0.13.1.1)

How reproducible:

All the time

Steps to reproduce :

Create a host and specify the scsi_controller_type compute-attributes

hammer host create --name "test.local" \
--organization "ORG" \
--location "location" \
--compute-resource host.vmware.local \
--compute-attributes="cpus=2,corespersocket=1,memory_mb=2048,cluster=PRODUCTION,path=TO_CLASS,start=1,guest_id=rhel7_64Guest,scsi_controller_type=ParaVirtualSCSIController,hardware_version=vmx-10" \
--provision-method build \
--build true \
--enabled true \
--managed true \
--interface "managed=true,primary=true,provision=true,compute_type=VirtualVmxnet3,compute_network=VLAN100" \
--hostgroup SOME_HOST_GROUP \
--ip 10.0.0.10 \
--volume="size_gb=20G,datastore=PROD,name=myharddisk,thin=true"

Actual results:

The VM is created with the "VirtualLsiLogicController" scsi controller

Expected results:

The VM is created with the "ParaVirtualSCSIController" scsi controller

Additional info:

I have changed the following lines

def scsi_controller_default_type
#"VirtualLsiLogicController"
"ParaVirtualSCSIController"
end

in /usr/share/foreman/app/models/compute_resources/foreman/model/vmware.rb

to at least default to ParaVirtualSCSIController.

Note that this may be either in API or hammer, but based on what I've seen, it's probably API, so opening the issue in Foreman project.


Related issues

Related to Foreman - Bug #26756: Drop invalid scsi_controller_type attributeClosed

Associated revisions

Revision ae8b3921 (diff)
Added by Ondřej Ezr 9 months ago

Fixes #26402 - VMware scsi_controller type from hammer (#6595)

History

#1 Updated by The Foreman Bot 9 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6595 added

#2 Updated by Ondřej Ezr 9 months ago

  • Triaged changed from No to Yes
  • Difficulty set to easy
  • Assignee set to Ondřej Ezr

The hammer option scsi_controller_type is actually never used and I haven't found a in a history when it was, but I guess it doesn't work since we support multiple scsi_controllers.

#3 Updated by Marek Hulán 9 months ago

  • Fixed in Releases 1.22.0 added

#4 Updated by Anonymous 9 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Ondřej Ezr 7 months ago

  • Related to Bug #26756: Drop invalid scsi_controller_type attribute added

Also available in: Atom PDF