Project

General

Profile

Bug #26470

"Red Hat Registry" is ambiguous

Added by Brad Buckingham over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1673326

We have introduced repository discovery for container registries. To streamline user experience, we have three most popular registries available in dropdown field. One of them is called "Red Hat Registry".

The problem is, Red Hat currently maintains three registries: registry.access.redhat.com, registry.redhat.io and registry.connect.redhat.com. Users can reasonably expect "Red Hat Registry" to mean any one of these.

How do we unambiguously communicate which one will be used when this value is selected?


Based upon offline discussion, we'll clarify the Red Hat Registry represents registry.redhat.io.

Associated revisions

Revision 2d46c667 (diff)
Added by Brad Buckingham over 2 years ago

Fixes #26470 - clarify 'Red Hat Registry' is registry.redhat.io

Since there are currently mutliple registries from Red Hat,
this change is to make it clear that the registry selected
is registry.redhat.io.

If the user would like to specify a different registry,
it is still possible to select 'Custom' and provide the
URL and credentials for that registry.

History

#1 Updated by The Foreman Bot over 2 years ago

  • Assignee set to Brad Buckingham
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8047 added

#2 Updated by Andrew Kofink over 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.12.0
  • Subject changed from "Red Hat Registry" is ambiguous to "Red Hat Registry" is ambiguous

#3 Updated by Brad Buckingham over 2 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF