Project

General

Profile

Bug #2655

Missing buttons on host page with non-managed hosts

Added by Michael Moll almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Low
Category:
Web Interface
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

On a host page the buttons "Facts", "Reports" and "YAML" are not displayed anymore if the host is non-managed.
They were there in 1.1.

Associated revisions

Revision e902d939 (diff)
Added by Greg Sutcliffe almost 6 years ago

Fixes #2655 - Display Host buttons on unmanaged hosts if a puppet proxy exists

Revision dbcdb87f (diff)
Added by Greg Sutcliffe almost 6 years ago

Fixes #2655 - Display Host buttons on unmanaged hosts if a puppet proxy exists
(cherry picked from commit e902d93997b7ed04cc06cebe03674752fafc758d)

History

#1 Updated by Greg Sutcliffe almost 6 years ago

  • Status changed from New to Ready For Testing

This was caused by f7640652 in which these buttons are hidden when a host does not have an associated puppet proxy. However, hosts created by fact-upload will never have an associated puppet proxy ID, so we need to account for that.

https://github.com/theforeman/foreman/pull/712

#2 Updated by Michael Moll almost 6 years ago

The patch works for me

#3 Updated by Greg Sutcliffe almost 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF