Project

General

Profile

Bug #2662

Failed puppet run: undefined method `escape_for_shell' for Proxy::Puppet:Module

Added by Ivan Necas over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Urgent
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

$subject$ when trying to puppetrun via smart-proxy.

Changing:

def self.escape_for_shell(command)

to

def escape_for_shell(command)

Seems to work. I wonder, if there is a context where the original code works as well?

Associated revisions

Revision 4a8411d8 (diff)
Added by Dmitri Dolguikh over 7 years ago

fixes #2662 - Proxy::Util.escape_for_shell is being used in PuppetRun.run and MCollective.run methods

Revision a6c688a9 (diff)
Added by Dmitri Dolguikh over 7 years ago

fixes #2662 - Proxy::Util.escape_for_shell is being used in PuppetRun.run and MCollective.run methods
(cherry picked from commit 4a8411d8d8cfb7510dc8775b5b1b0a0c8c217c69)

History

#1 Updated by Dominic Cleal over 7 years ago

  • Priority changed from Normal to Urgent
  • Target version set to 1.2.0

Which version of the proxy is this?

This code was added in 216728d09495fe5a2940760df702910642853bca, so perhaps you're seeing it there. It seems I added a regression when merging 80f8a61f43504ec3a4753dda2ef201483e5ce855 though, which relocated the content and was written before the first fix.

I think we need to put the escape_for_shell code back, and make sure we don't hit this error again?

#2 Updated by Ivan Necas over 7 years ago

I'm running my custom build based on aff8fa8b4f7108b30c3e2ff6ec9068c9851e4d91, it seems the recent git doesn't have the problem, but I agree that escape_for_shell was there for a reason, so it should get back.

Thanks for REALLY quick response :)

#3 Updated by Dmitri Dolguikh over 7 years ago

Ivan - do you have a backtrace for this? Looks like Proxy::Util.escape_for_shell is not being used anywhere in smart-proxy/devel...

#4 Updated by Dominic Cleal over 7 years ago

Dmitri Dolguikh wrote:

Ivan - do you have a backtrace for this? Looks like Proxy::Util.escape_for_shell is not being used anywhere in smart-proxy/devel...

See the above comments, I accidentally removed the code in the second SHA above. This issue now becomes: please restore 216728d09495fe5a2940760df702910642853bca but without the undefined method bug :)

#5 Updated by Dmitri Dolguikh over 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Dmitri Dolguikh

#6 Updated by Dmitri Dolguikh over 7 years ago

  • Status changed from Assigned to Ready For Testing

#7 Updated by Anonymous over 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Greg Sutcliffe over 2 years ago

  • Target version deleted (1.2.0)

Also available in: Atom PDF