Project

General

Profile

Actions

Bug #26746

closed

No visible progress during --upgrade-mongo-storage-engine

Added by Chris Roberts about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
foreman-installer script
Target version:
Difficulty:
trivial
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Description of problem:
When running satellite-installer --upgrade-mongo-storage-engine, it will first dump the MongoDB database and then restore it with the new storage engine.

While restoring, it runs
mongorestore --host localhost --db=pulp_database --drop --quiet --dir=/var/tmp/mongodb_engine_upgrade/pulp_database

And with --quiet there is zero output on the terminal. (There is during the dump phase).
As this step can easily take multiple hours, it'd be nice to see some progress, even if it's as badly formatted as the one during the dump

Version-Release number of selected component (if applicable):
6.5.0 Snap 26

How reproducible:
100%

Steps to Reproduce:
1. Install 6.3 (last one to default to MMAPv1 for new installs)
2. Upgrade to 6.4/6.5
3. satellite-installer --upgrade-mongo-storage-engine

Actual results:
No output during restore

Expected results:
Output during restore

Additional info:
Just removing the --quiet should be sufficient

Actions #1

Updated by The Foreman Bot about 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-installer/pull/352 added
Actions #2

Updated by Chris Roberts about 5 years ago

  • Status changed from Ready For Testing to Closed
Actions #3

Updated by Tomer Brisker about 5 years ago

  • Fixed in Releases 1.23.0 added
Actions

Also available in: Atom PDF