Project

General

Profile

Bug #26767

Empty repository list when using bulk action for Manage Repository Sets

Added by Marco G 5 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

The repository list in the bulk/select action for Manage Repository Sets is empty if user have only custom products (CentOS, EPEL, ...)

How reproducible: 100%

Steps to Reproduce:
1. Create a custom product
2. Create a repository in a custom product
3. Goto Hosts -> Content Hosts
4. Select one or more hosts with checkbox
5. Select Action (Dropdown) -> Manage Repository Sets

Actual results:
Repository list is empty with the message 'No enabled Repository Sets provided through subscriptions.'

Expected results:
Ability to change Repository Sets for hosts selected, like in Host -> Content Hosts -> HOST -> Repository Sets

Associated revisions

Revision 8765d159 (diff)
Added by sjha4 3 months ago

Fixes #26767 - Custom products on bulk content host manage page

History

#1 Updated by Marco G 5 months ago

  • Priority changed from High to Normal

#2 Updated by Justin Sherrill 5 months ago

  • Bugzilla link set to 1678179

#3 Updated by John Mitsch 5 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.13.0

#4 Updated by The Foreman Bot 3 months ago

  • Assignee set to Samir Jha
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8191 added

#5 Updated by Marco G 3 months ago

I've applied the changes on my Katello 3.10.1, but I'm not able to see any repositories. Using the API 'repository_set' I get 0 results:

-> https://katello.example.com/katello/api/v2/repository_sets

<- {"total":0,"subtotal":0,"page":1,"per_page":20,"error":null,"search":null,"sort":{"by":"name","order":"asc"},"results":[]}

Maybe the problem is that I don't have any redhat repos nor any redhat repository sets. Does your patch return "custom repository sets along with redhat repos" and "custom repository sets even without any redhat repos" ?

Thanks,
Marco

#7 Updated by Marco G 3 months ago

Using that endpoint, I get all my repositories:

{"total":24,"subtotal":24,"page":1,"per_page":20,"error":null,"search":null,"sort":{"by":"name","order":"asc"},"results":[{"enabled":null,"product":{"id":1,"name":"CentOS"},"repositories":[{"id":8,"name":"CentOS 7.3.1611 Base ....

Maybe do I have to do something else after modifying 'content-hosts-bulk-repository-sets-modal.controller.js' file ?

#8 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases Katello 3.14.0 added

#9 Updated by Anonymous 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF