Project

General

Profile

Bug #26865

command "hammer full-help" gives error "Error: undefined method `action' for false:FalseClass"

Added by Oleh Fedorenko 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
Other commands
Target version:
-
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1712914

Description of problem:
command "hammer full-help" gives error "Error: undefined method `action' for false:FalseClass"

Version-Release number of selected component (if applicable):
@Satellite 6.6.0 snap 3
@tfm-rubygem-hammer_cli-0.17.1-1.el7sat.noarch

How reproducible:
always

Steps to Reproduce:
1. Run # hammer full-help

Actual results:
- gives full-help output till "hammer > docker > container > info" command after that shows error "Error: undefined method `action' for false:FalseClass"

Expected results:
- command 'hammer full-help' should run without any error and provide complete full-help output.

Additional info:


Related issues

Has duplicate Hammer CLI - Bug #26864: command "hammer full-help" gives error "Error: undefined method `action' for false:FalseClass"Duplicate

Associated revisions

Revision 943ea36b (diff)
Added by Oleh Fedorenko 5 months ago

Fixes #26865 - action for false:FalseClass

Revision 097d3b01 (diff)
Added by Oleh Fedorenko 5 months ago

Refs #26865 - Resource or nil

History

#1 Updated by Oleh Fedorenko 5 months ago

The problem is in hammer-cli-foreman-docker plugin which is being installed alongside with hammer-cli-katello.

Since foreman_docker is not maintained anymore [1] I guess we should drop support for it in the future hammer versions as well (hammer-cli-katello has hammer-cli-foreman-docker as dependency [2]). Removing it from there should remove all the docker commands hence this bug will not reproducible.

[1] https://github.com/theforeman/foreman_docker
[2] https://github.com/Katello/hammer-cli-katello/blob/1eb1b7948377760e26ecc69030a5cba387e8bc90/hammer_cli_katello.gemspec#L53

#2 Updated by Oleh Fedorenko 5 months ago

  • Triaged changed from No to Yes
  • Difficulty set to trivial
  • Assignee set to Oleh Fedorenko
  • Status changed from New to Assigned

#3 Updated by Oleh Fedorenko 5 months ago

  • Has duplicate Bug #26864: command "hammer full-help" gives error "Error: undefined method `action' for false:FalseClass" added

#4 Updated by The Foreman Bot 5 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/421 added

#5 Updated by The Foreman Bot 5 months ago

  • Pull request https://github.com/theforeman/hammer-cli/pull/304 added

#6 Updated by Oleh Fedorenko 5 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF