Project

General

Profile

Actions

Refactor #26882

closed

Update fact importer for Foreman 1.23

Added by Anonymous about 5 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

ActiveSupport::DeprecationException: DEPRECATION WARNING: You are using a deprecated behavior, it will be removed in version 1.23, FactImporter.db_facts will be removed, use host.fact_values instead and filter values manually (called from missing_facts at /home/jenkins/workspace/foreman_ansible-pull-request@2/database/postgresql/label/fast/ruby/2.5/plugin/app/services/foreman_ansible/fact_importer.rb:58)...


Related issues 1 (0 open1 closed)

Related to Foreman - Bug #25923: Puppet fact processing failed for hosts with large number of LUNs attachedClosedLukas ZapletalActions
Actions #1

Updated by Anonymous about 5 years ago

  • Related to Bug #25923: Puppet fact processing failed for hosts with large number of LUNs attached added
Actions #2

Updated by Ondřej Ezr about 3 years ago

  • Status changed from New to Rejected

We couldn't reproduce, I believe it is already fixed.
If you're still facing this, feel free to reopen.

Actions

Also available in: Atom PDF