Project

General

Profile

Bug #26902

'uuid' option removed from command "hammer content-view puppet-module list"

Added by John Mitsch almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1711929

Description of problem:
'uuid' option removed from command "hammer content-view puppet-module list --help"

How reproducible:
always

Steps to Reproduce:
1.Run # hammer content-view puppet-module list --help

Actual results:
  1. hammer content-view puppet-module list --help
    Usage:
    hammer content-view puppet-module list [OPTIONS]

Options:
--author AUTHOR Author of the puppet module
--content-view CONTENT_VIEW_NAME Content view name to search by
--content-view-id CONTENT_VIEW_ID Content view numeric identifier
--full-result FULL_RESULT Whether or not to show all results
One of true/false, yes/no, 1/0.
--name NAME Name of the puppet module
--order ORDER Sort field and order, eg. 'id DESC'
--organization ORGANIZATION_NAME Organization name to search by
--organization-id ORGANIZATION_ID Organization ID to search by
--organization-label ORGANIZATION_LABEL Organization label to search by
--page PAGE Page number, starting at 1
--per-page PER_PAGE Number of results per page to return
--search SEARCH Search string
-h, --help Print help

Expected results:
  1. hammer content-view puppet-module list --help
    Usage:
    hammer content-view puppet-module list [OPTIONS]

Options:
--author AUTHOR Author of the puppet module
--content-view CONTENT_VIEW_NAME Content view name to search by
--content-view-id CONTENT_VIEW_ID Content view numeric identifier
--full-result FULL_RESULT Whether or not to show all results
One of true/false, yes/no, 1/0.
--name NAME Name of the puppet module
--order ORDER Sort field and order, eg. 'id DESC'
--organization ORGANIZATION_NAME Organization name to search by
--organization-id ORGANIZATION_ID Organization ID to search by
--organization-label ORGANIZATION_LABEL Organization label to search by
--page PAGE Page number, starting at 1
--per-page PER_PAGE Number of results per page to return
--search SEARCH Search string
--uuid UUID The uuid of the puppet module to associate
-h, --help Print help

Additional info:

Associated revisions

Revision c58e1825 (diff)
Added by John Mitsch almost 3 years ago

Fixes #26902 - Add uuid param back to CV puppet environment

This param was removed [here](https://github.com/Katello/katello/commit/0d5a1ebe7d722113d16146d6f98b6d2a39c351c0#diff-b3f64de16869054a88473910f7fef5cfL12), rightfully so since it only grabs a single puppet module, which is what the show call is for. However, we should deprecate the param like we have the other one in the POST call

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Assignee set to John Mitsch
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8135 added

#2 Updated by John Mitsch almost 3 years ago

  • Status changed from Ready For Testing to Closed

#3 Updated by Brad Buckingham almost 3 years ago

  • Target version set to Katello 3.12.0
  • Subject changed from 'uuid' option removed from command "hammer content-view puppet-module list" to 'uuid' option removed from command "hammer content-view puppet-module list"

#4 Updated by Andrew Kofink almost 3 years ago

  • Triaged changed from No to Yes

#5 Updated by Chris Roberts almost 3 years ago

  • Fixed in Releases Katello 3.12.0 added

Also available in: Atom PDF