Project

General

Profile

Actions

Bug #26926

closed

hammer cli wipes host parameters when build is toggled (UI or API does not)

Added by Will Foster almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Hosts
Target version:
-
Difficulty:
Triaged:
No
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Hello,

We're noticing that on Foreman 1.19.1 using hammer cli to toggle build status will wipe previously made host parameters. Doing the same thing via the UI does not do this.

We make heavy use of host params in our automation so this is painful for us. I couldn't find anything around this so filing this here. It seems that the behavior should work the same in both UI and hammer cli (host params should not be touched if build status toggled).

Below I've made some videos displaying this behavior

(host params left intact via marking host for build with UI)

https://www.youtube.com/watch?v=Q2C4NehcC1U

(using hammer cli and marking for build wipes host params)

https://www.youtube.com/watch?v=xkMWgmUcUzo&feature=youtu.be


Files

26926_hammer_cli_debug.txt 26926_hammer_cli_debug.txt 14.5 KB hammer cli debug Will Foster, 05/31/2019 03:29 PM
26926_hammer_api_curl_build.txt 26926_hammer_api_curl_build.txt 4.97 KB output by toggling build status via curl/API Will Foster, 05/31/2019 03:52 PM

Related issues 1 (0 open1 closed)

Is duplicate of Hammer CLI - Bug #20725: 'hammer host update' removes existing host parametersClosedRahul BajajActions
Actions

Also available in: Atom PDF