Project

General

Profile

Feature #26934

Bootdisk autoattach does not work for rebuild

Added by Richard Stempfl almost 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When using the bootdisk plugin, the rebuild of hosts does not work.

The hosts are restarted correctly and thus behave correctly - with the missing step that the bootdisk iso is not included for the reboot and therefore no reinstallation is triggered.

Since this integration works with the Create Host, it should be possible to use this step also with a rebuild.

Associated revisions

Revision 28e41522 (diff)
Added by Bernhard Suttner 11 months ago

Fixes #26934 - Detach ISO after build

Fixes #26824, too

Detach the ISO Image after build. Attach the ISO image and mark with "start_connected" is necessary so that rebuild the host works (otherwise vmware would simply disconnect the iso if you reboot the host). Important: the provisioning template need to eject the cdrom BEFORE detach is possible.

History

#1 Updated by Tomer Brisker almost 2 years ago

  • Category deleted (Compute resources)
  • Project changed from Foreman to Boot disk

#2 Updated by Lukas Zapletal almost 2 years ago

  • Triaged changed from No to Yes
  • Subject changed from Bootdisk rebuild fails to Bootdisk autoattach does not work for rebuild
  • Tracker changed from Bug to Feature

#3 Updated by Anonymous 11 months ago

  • Status changed from New to Closed

Also available in: Atom PDF