Project

General

Profile

Bug #26941

NoMethodError: undefined method `[]' for nil:NilClass

Added by Ondřej Ezr about 1 year ago. Updated 4 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Reporting
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1714645

Description of problem:
When generating a report, sometimes, after getting to Download page, the error "Internal Server Error: the server was unable to finish the request. This may be caused by unavailability of some required service, incorrect API call or a server-side bug. There may be more information in the server's logs." is shown and the report is not generated.
There is "NoMethodError: undefined method `[]' for nil:NilClass" with traceback in production.log (attached).

This only happened to me once and I don't know how to trigger it. The only nonstandard thing in that case was "Generate at" set to past but I couldn't reproduce again this way.

Version-Release number of selected component (if applicable):
Reproduced on Sat 6.6 snap 4.

How reproducible:
Only happened once (in ~ 100 attempts)

Steps to Reproduce:
1. Monitoring -> Report Templates
2. Generate any template
3. Submit

Actual results:
Sometimes, it fails with an error and traceback

Expected results:
This should always work

History

#1 Updated by Tomer Brisker 4 months ago

  • Category changed from Statistics to Reporting

Also available in: Atom PDF