Project

General

Profile

Bug #26942

NoMethodError on generating report template

Added by Ondřej Ezr 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Reporting
Target version:
-
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1714645

Description of problem:
When generating a report, sometimes, after getting to Download page, the error "Internal Server Error: the server was unable to finish the request. This may be caused by unavailability of some required service, incorrect API call or a server-side bug. There may be more information in the server's logs." is shown and the report is not generated.
There is "NoMethodError: undefined method `[]' for nil:NilClass" with traceback in production.log (attached).

This only happened to me once and I don't know how to trigger it. The only nonstandard thing in that case was "Generate at" set to past but I couldn't reproduce again this way.

Version-Release number of selected component (if applicable):
Reproduced on Sat 6.6 snap 4.

How reproducible:
Only happened once (in ~ 100 attempts)

Steps to Reproduce:
1. Monitoring -> Report Templates
2. Generate any template
3. Submit

Actual results:
Sometimes, it fails with an error and traceback

Expected results:
This should always work

Associated revisions

Revision 12c21c15 (diff)
Added by Ondřej Ezr 6 months ago

Fixes #26942 - no plan info retrieval if not done (#6820)

History

#1 Updated by Ondřej Ezr 6 months ago

  • Triaged changed from No to Yes
  • Difficulty set to easy
  • Category changed from Statistics to Reporting
  • Found in Releases 1.22.1 added

#2 Updated by Ondřej Ezr 6 months ago

  • Subject changed from NoMethodError: undefined method `[]' for nil:NilClass to NoMethodError on generating report template

#3 Updated by The Foreman Bot 6 months ago

  • Assignee set to Ondřej Ezr
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6820 added

#4 Updated by Marek Hulán 6 months ago

  • Fixed in Releases 1.23.0 added

#5 Updated by Ondřej Ezr 6 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF