Project

General

Profile

Actions

Bug #27015

closed

Deploying a New Host to vmware compute resource from existing template always ends up with thin provisioned disk

Added by Marek Hulán almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1378579

Description of problem:
Create a New Host, destined for a Vmware compute resource, image based off an existing template in Vmware. When the new host is deployed, it will always have thin provisioned disks.

Version-Release number of selected component (if applicable):
6.2.1

How reproducible:
Every Time

Steps to Reproduce:
1. Create a New Host, destined for a Vmware compute resource, image based off an existing template in Vmware.
2. Go into Vmware, right click settings, and look at disk
3. Disk will be thin provisioned, even though the template or any settings in WebUI are requesting thick

Additional info:
fog-vsphere gem, requests/compute/vm_cloen.rb, approx line 583, is looking for an
options['transform'] setting that doesnt get set anywhere by Satellite it seems.

`relocation_spec = RbVmomi::VIM.VirtualMachineRelocateSpec(:pool => resource_pool,:transform => options['transform'] || 'sparse')`

Since it's not set, it defaults to 'sparse' which makes it thin. If I hard code this line to be ":transform => 'flat'", it'll deploy thick provisioned lazy zero, as I need.

Actions #1

Updated by Ondřej Ezr almost 5 years ago

  • Subject changed from Deploying a New Host to vmware compute resource from existing template always ends up with thin provisioned disk to Deploying a New Host to vmware compute resource from existing template always ends up with thin provisioned disk
  • Assignee set to Ondřej Ezr
  • Triaged changed from No to Yes
  • Fixed in Releases 1.23.0 added
Actions #2

Updated by Ondřej Ezr almost 5 years ago

  • Status changed from New to Resolved
Actions #3

Updated by Marek Hulán almost 5 years ago

Resolved by #27313

Actions #4

Updated by Marek Hulán almost 5 years ago

  • Pull request https://github.com/theforeman/foreman-packaging/pull/3935 added
Actions

Also available in: Atom PDF