Project

General

Profile

Bug #27025

Validate JSON keyfile for authentication as P12 keyfile deprecated

Added by Kavita Gaikwad 10 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Low
Category:
Compute resources - GCE
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

As .p12 key deprecated, to connect google compute resource now it requires JSON key.
So, it would be good to validate key content to warn users to use correct key.

Associated revisions

Revision f5ce548a (diff)
Added by Kavita Gaikwad 8 months ago

Fixes #27025 - validate GCE key format (#6953)

History

#1 Updated by Kavita Gaikwad 10 months ago

  • Priority changed from Normal to Low

#2 Updated by The Foreman Bot 8 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6953 added

#3 Updated by The Foreman Bot 8 months ago

  • Fixed in Releases 1.24.0 added

#4 Updated by Kavita Gaikwad 8 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF