Project

General

Profile

Refactor #27053

Drop Puppet 3 support from the proxy

Added by Ewoud Kohl van Wijngaarden 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
Foreman modules
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

It's been deprecated and the code doesn't run on Puppet 3 anymore so there's no way to deploy it.


Related issues

Related to Smart Proxy - Feature #26591: Raise minimum Puppet version to 4.4Closed

Associated revisions

Revision 9939f88c (diff)
Added by Ewoud Kohl van Wijngaarden 5 months ago

Fixes #27053 - Drop Puppet 3 support from the proxy

This drops support for the puppet_proxy_legacy and
puppet_proxy_puppetrun classes. These have been depcated for some time
and there's no way to deploy this anymore given this module is Puppet 4+
for some time.

History

#1 Updated by Ewoud Kohl van Wijngaarden 6 months ago

  • Related to Feature #26591: Raise minimum Puppet version to 4.4 added

#2 Updated by The Foreman Bot 6 months ago

  • Assignee set to Ewoud Kohl van Wijngaarden
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-foreman_proxy/pull/514 added

#3 Updated by Ewoud Kohl van Wijngaarden 5 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF