Project

General

Profile

Bug #27151

The Host configuration chart shows 100% even if few hosts are not in sync or reporting.

Added by Marek Hulán about 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Dashboard
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1666324

Description of problem:

"Host configuration chart for Puppet" on Dashboard shows 100% ok, even though there are eg. 2 out of 1000 hosts in "out of sync".
The problem here is: When it says 100% ok, it should mean all - not almost all.

This problem is probably due to a roundup function that makes everything above and equal to 99.5% into 100% in the graph.
While the calculation is mathematically correct, it is pretty misleading, since you can not have fractions of a host.

Examples:
  • When 99.75% out of 1000 hosts are OK, it should show 99% and not 100%.

Version-Release number of selected component (if applicable):

Red Hat Satellite 6.3.4

How reproducible:

100%

Actual results:

When it says 100% ok, it should mean all whereas it is not the case here.

Expected results:

It should not show 100% if some host is still not proper this could mislead.

Associated revisions

Revision 21fba8ae (diff)
Added by Amir Fefer over 2 years ago

Fixes #27151 - fixing falsy 100% in charts

History

#1 Updated by Marek Hulán about 3 years ago

  • Subject changed from The Host configuration chart shows 100% even if few hosts are not in sync or reporting. to The Host configuration chart shows 100% even if few hosts are not in sync or reporting.

This is still reproducible with current nightly. Just mock the report data that hosts ok are 100 000, you'll see 100% is ok.

#2 Updated by The Foreman Bot over 2 years ago

  • Assignee set to Amir Fefer
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7542 added

#3 Updated by The Foreman Bot over 2 years ago

  • Fixed in Releases 2.1.0 added

#4 Updated by Amir Fefer over 2 years ago

  • Status changed from Ready For Testing to Closed

#5 Updated by The Foreman Bot over 2 years ago

  • Pull request https://github.com/theforeman/foreman/pull/7548 added

#6 Updated by Tomer Brisker almost 2 years ago

  • Pull request deleted (https://github.com/theforeman/foreman/pull/7548)

Also available in: Atom PDF