Project

General

Profile

Bug #2717

Run validation on automatically added hosts

Added by Brian Rak almost 8 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I have a couple hosts that automatically get duplicates added (because the FQDN doesn't match what Foreman thinks it is, this is an entirely separate issue). What I've noticed is that the automatically added hosts don't validate that they are unique. For example, the automatically added hosts have the same mac/ip as the real host. Foreman notices this if I go back and try to edit the real host.

Validation of parameters should probably be performed for any hosts that get automatically added.

History

#1 Updated by Leos Stejskal 2 months ago

  • Status changed from New to Closed
  • Description updated (diff)

I'm closing the issue,
it's here for some time and I wasn't able to reproduce it on latest version.
If you believe that the issue is still relevant feel free to reopen it.

Also available in: Atom PDF