Project

General

Profile

Bug #27198

UI sends malformed API request upon enabling *first* redhat repo

Added by Samir Jha 3 months ago. Updated 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

The API call made to get enabled repos is possibly malformed and looks like /katello/api/v2/repositories?organization_id=1&enabled=true&page=0&per_page=NaN&search=(redhat+%3D+true)
with the response: {"displayMessage":"invalid page: 0","errors":["invalid page: 0"]}

Notice page=0&per_page=NaN in the request.

Works ok after refresh with the API call /katello/api/v2/repositories?organization_id=1&enabled=true&search=(redhat+%3D+true)


Related issues

Is duplicate of Katello - Bug #27426: enabled repository does not show under 'Enabled Repository' view without refresh the pageClosed

History

#1 Updated by Chris Roberts 3 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.13.0

#2 Updated by The Foreman Bot 2 months ago

  • Assignee set to Samir Jha
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8254 added

#3 Updated by Samir Jha 2 months ago

  • Is duplicate of Bug #27426: enabled repository does not show under 'Enabled Repository' view without refresh the page added

#4 Updated by Samir Jha 2 months ago

  • Status changed from Ready For Testing to Duplicate

Also available in: Atom PDF