Project

General

Profile

Bug #27224

fg: no job control in post scriptlet while installing foreman

Added by Ewoud Kohl van Wijngaarden 6 months ago. Updated 5 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

While installing Foreman the following error shows up in the output:

/var/tmp/rpm-tmp.eSpJPO: line 7: fg: no job control

The posttrans scriptlet in the Foreman RPM:

# rpm -q --scripts foreman
...
posttrans scriptlet (using /bin/sh):
# We need to run the db:migrate after the install transaction
# always attempt to reencrypt after update in case new fields can be encrypted
/usr/sbin/foreman-rake db:migrate db:encrypt_all >> /var/log/foreman/db_migrate.log 2>&1 || :
/usr/sbin/foreman-rake db:seed >> /var/log/foreman/db_seed.log 2>&1 || :
/usr/sbin/foreman-rake apipie:cache:index >> /var/log/foreman/apipie_cache.log 2>&1 || :
/usr/sbin/foreman-rake tmp:clear >> /var/log/foreman/tmp_clear.log 2>&1 || :
%{foreman_restart} || :
exit 0

Note the un-expanded %{foreman_restart}


Related issues

Is duplicate of Packaging - Bug #27225: fg: no job control in post scriptlet while installing foremanClosed

History

#1 Updated by Ewoud Kohl van Wijngaarden 5 months ago

  • Is duplicate of Bug #27225: fg: no job control in post scriptlet while installing foreman added

#2 Updated by Ewoud Kohl van Wijngaarden 5 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF